summaryrefslogtreecommitdiff
path: root/x11-toolkits/libxfce4gui/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-28 18:10:40 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-28 18:10:40 +0000
commitbe12963ff8818dee38fb3016aeb0631fff746c93 (patch)
treef91f6a714feb1fe442b82e57608803e561f50f4e /x11-toolkits/libxfce4gui/Makefile
parentSubmitted by: "Pyun YongHyeon" <yongari@kt-is.co.kr> (diff)
Add libxfce4gui 3.99.2,
xFce 4 widget library required by xfce4 and xfwm4. PR: 53155 Submitted by: James Earl <jdearl@telus.net>
Diffstat (limited to 'x11-toolkits/libxfce4gui/Makefile')
-rw-r--r--x11-toolkits/libxfce4gui/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/libxfce4gui/Makefile b/x11-toolkits/libxfce4gui/Makefile
new file mode 100644
index 000000000000..ffc09703704b
--- /dev/null
+++ b/x11-toolkits/libxfce4gui/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libxfce4util
+# Date created: 7 June 2003
+# Whom: James Earl <jdearl@telus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxfce4gui
+PORTVERSION= 3.99.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.xfce.org/archive/xfce4-rc2/src/ \
+ ftp://ftp.unix-ag.org/user/bmeurer/xfce4/rc2/separate/ \
+ http://usuarios.lycos.es/xfce4/tarballs/rc2/separate/ \
+ http://linux.imp.mx/xfce4/rc2/xfce4-rc2/src/
+DISTNAME= libxfcegui4-${PORTVERSION}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XFce 4 widget library required by xfce4 and xfwm4
+
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util
+
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/libxfcegui4/Makefile.in
+
+.include <bsd.port.mk>