summaryrefslogtreecommitdiff
path: root/x11-toolkits/gob/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-01-25 11:13:57 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-01-25 11:13:57 +0000
commit31294ef072a80be517c5761069ea5f03a29fc672 (patch)
tree2b38868a71bc3baf94710c881e24c9a112af9d8d /x11-toolkits/gob/Makefile
parentClaim maintainership of a port I submitted. (diff)
Initial import.
GTK+ Object Builder. This is merely a preprocessor for GTK+, and seems to be more important for GTK+/GNOME applicatoin development.
Diffstat (limited to 'x11-toolkits/gob/Makefile')
-rw-r--r--x11-toolkits/gob/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/gob/Makefile b/x11-toolkits/gob/Makefile
new file mode 100644
index 000000000000..5c58d35cfadf
--- /dev/null
+++ b/x11-toolkits/gob/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: GTK+ Object Builder
+# Version required: 0.92.2
+# Date created: 25 January 2000
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= gob-0.92.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://ftp.5z.com/pub/gob/
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= gob.1
+
+.include <bsd.port.mk>