summaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-06-26 12:02:37 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-06-26 12:02:37 +0000
commit715b332be2549027eead5f57212c5b4b1106099d (patch)
tree435ff4bd1e34c45d93ad050d83d695fb8c22cdb0 /x11-toolkits/gnustep-gui/Makefile
parentUpgrade to 1.0.2. (diff)
Upgrade to 0.6.9.
Diffstat (limited to 'x11-toolkits/gnustep-gui/Makefile')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile62
1 files changed, 34 insertions, 28 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index c1b8fa61d1fc..422158987ac3 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -1,21 +1,22 @@
-# New ports collection makefile for: gnustep
-# Date created: 03 October 1998
+# New ports collection makefile for: gnustep-gui
+# Date created: 19 April 2001
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gnustep
-PORTVERSION= 0.6.6
-CATEGORIES= devel
-MASTER_SITES= http://ftp.codefactory.se/pub/gnu/gstep/ \
+PORTNAME= gnustep-gui
+PORTVERSION= 0.6.9
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/ \
+ http://ftp.codefactory.se/pub/gnu/gstep/ \
http://planetmirror.com/pub/gnustep/core/
-DISTNAME= gstep-core-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- tiff.4:${PORTSDIR}/graphics/tiff
+BUILD_DEPENDS= ${SYSLIBDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-base.so:${PORTSDIR}/devel/gnustep-base
+RUN_DEPENDS= ${SYSLIBDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-base.so:${PORTSDIR}/devel/gnustep-base
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
.include <bsd.port.pre.mk>
@@ -23,20 +24,11 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.endif
-USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
-WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_NEWGCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
-CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
- --with-jpeg-library=${LOCALBASE}/lib \
- --with-jpeg-include=${LOCALBASE}/include \
- --with-tiff-library=${LOCALBASE}/lib \
- --with-tiff-include=${LOCALBASE}/include # --enable-threads=posix
CONFIGURE_TARGET=
-USE_BISON= yes
USE_GMAKE= yes
-USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
@@ -46,18 +38,32 @@ GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
-ETCDIR= ${PREFIX}/../etc
+SYSLIBDIR= ${PREFIX}/System/Libraries
-post-patch:
-.for f in bundle gswapp gswbundle woapp wobundle
- ${PERL} -pi -e 's/\$$\(TAR\) ch --exclude=CVS --to-stdout/\$$\(TAR\) -ch --exclude=CVS -f -/g' ${WRKSRC}/make/${f}.make
+post-extract:
+.for file in config.guess config.sub install-sh
+ @${CP} ${PREFIX}/System/Makefiles/${file} ${WRKSRC}
.endfor
-post-install:
- @${MKDIR} ${ETCDIR}
- ${INSTALL_SCRIPT} ${FILESDIR}/GNUstep.sh ${ETCDIR}/rc.d
- ${INSTALL_DATA} ${FILESDIR}/gdomap_if ${ETCDIR}
+do-configure:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
+ INSTALL_DATA="${INSTALL} -c" \
+ INSTALL_PROGRAM="${INSTALL} -c" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; then \
+ ${ECHO} "===> Script \"${CONFIGURE_SCRIPT}\" failed: here are the contents of \"${CONFIGURE_LOG}\""; \
+ ${CAT} ${CONFIGURE_LOG}; \
+ ${ECHO} "(end of \"${CONFIGURE_LOG}\")"; \
+ ${FALSE}; \
+ fi)
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
.include <bsd.port.post.mk>