summaryrefslogtreecommitdiff
path: root/x11-toolkits/XawPlus/files
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-09-04 14:51:06 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-09-04 14:51:06 +0000
commit09bec99b1628507efc22b88db142df16c042a81a (patch)
treeaa3bc2aa6b1558e1dc830a5f119dd9ca4ca4ae8f /x11-toolkits/XawPlus/files
parentUpdate WWW after the site moved to it's own domain (diff)
. Add a port of XawPlus:
XawPlus is a clone of the original Xaw library, providing a more up to date look and some extensions to the original Athena widget set. This library is as compatible as possible to the original. It should be possible to compile the source code of an Xaw client without any changes (except the include path of the XawPlus header files) to get the new look of XawPlus to this client. XawPlus makes it possible to use XPM pixmaps, tooltips, a truncate mechanism for too long label strings and UTF8 coded UNICODE labels without changing the code of your application. XawPlus comes with a set of adapted applications using also the new features of XawPlus. WWW: http://people.freenet.de/kra/XawPlus PR: 47700 Submitted by: Normal User <freebsd@falx.port5.com>
Diffstat (limited to 'x11-toolkits/XawPlus/files')
-rw-r--r--x11-toolkits/XawPlus/files/patch-Makefile60
-rw-r--r--x11-toolkits/XawPlus/files/patch-test::Makefile66
2 files changed, 126 insertions, 0 deletions
diff --git a/x11-toolkits/XawPlus/files/patch-Makefile b/x11-toolkits/XawPlus/files/patch-Makefile
new file mode 100644
index 000000000000..0332adb09ffe
--- /dev/null
+++ b/x11-toolkits/XawPlus/files/patch-Makefile
@@ -0,0 +1,60 @@
+$FreeBSD$
+
+--- Makefile.orig Sat Sep 7 12:59:26 2002
++++ Makefile Wed Jan 29 17:09:14 2003
+@@ -22,9 +22,9 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ #
+
+-LIB_PATH = -L/usr/X11/lib # Libraries for X
+-INC_PATH = -I. -I/usr/X11/include # Header files for X
+-INST_LIBS= /usr/X11/lib
++LIB_PATH = -L${X11BASE}/lib # Libraries for X
++INC_PATH = -I. -I${X11BASE}/include # Header files for X
++INST_LIBS= ${PREFIX}/lib
+
+ XAW= ./X11/XawPlus
+
+@@ -39,10 +39,12 @@
+ MenuButton.o Toggle.o Panner.o Command.o Repeater.o \
+ Grip.o Scrollbar.o List.o \
+ Tree.o DrawingArea.o StripChart.o Dialog.o
++all: lib
+
+-all: lib install
+ lib: libXawPlus.a libXawPlus.so.3.1 libXaw.so.6.6 libXaw.so.7.0
+
++.PHONY: clean
++
+ clean:
+ rm -f *.o *.a *.so*
+
+@@ -53,7 +55,7 @@
+
+ libXawPlus.so.3.1: $(OBJS)
+ $(CC) -shared -Wl,-soname,libXawPlus.so.3 \
+- -o libXawPlus.so.3.1 $(OBJS)
++ -o libXawPlus.so.3 $(OBJS)
+
+ libXaw.so.6.6: $(OBJS)
+ $(CC) -shared -Wl,-soname,libXaw.so.6 \
+@@ -66,14 +68,14 @@
+ # --- This only works as superuser root
+
+ install:
+- rm -rf /usr/X11/include/X11/XawPlus
+- mkdir -p /usr/X11/include/X11/XawPlus
+- cp ./X11/XawPlus/*.h /usr/X11/include/X11/XawPlus
++ rm -rf ${PREFIX}/include/X11/XawPlus
++ mkdir -p ${PREFIX}/include/X11/XawPlus
++ ${BSD_INSTALL_DATA} ./X11/XawPlus/*.h ${PREFIX}/include/X11/XawPlus
+ cp libXawPlus.a $(INST_LIBS)
+ rm -f $(INST_LIBS)/libXawPlus.so.3 $(INST_LIBS)/libXawPlus.so
+- cp libXawPlus.so.3.1 $(INST_LIBS)
++ ${BSD_INSTALL_DATA} libXawPlus.so.3 $(INST_LIBS)
+ ldconfig
+- ln -s $(INST_LIBS)/libXawPlus.so.3.1 $(INST_LIBS)/libXawPlus.so
++ ln -s $(INST_LIBS)/libXawPlus.so.3 $(INST_LIBS)/libXawPlus.so
+
+ installxaw:
+ rm -f $(INST_LIBS)/libXaw.so.6 \
diff --git a/x11-toolkits/XawPlus/files/patch-test::Makefile b/x11-toolkits/XawPlus/files/patch-test::Makefile
new file mode 100644
index 000000000000..e0450de740ab
--- /dev/null
+++ b/x11-toolkits/XawPlus/files/patch-test::Makefile
@@ -0,0 +1,66 @@
+$FreeBSD$
+
+--- test/Makefile.orig Sat Aug 10 13:14:54 2002
++++ test/Makefile Wed Jan 29 15:59:24 2003
+@@ -1,13 +1,13 @@
+ #
+-# Makefile fot the test programs
+-# This makefile requires libXawPlus.a in the
+-# parent directory !
++# Makefile for the test programs
+ #
+ # Roland Krause 2000
+ #
+
+-LIB_PATH = -L/usr/X11/lib # Libraries for X
+-INC_PATH = -I/usr/X11/include # Header for X
++PREFIX=%%X11BASE%%
++
++LIB_PATH = -L$(PREFIX)/lib # Libraries for X
++INC_PATH = -I$(PREFIX)/include # Header for X
+ LIBRARIES = -lXmu -lXext -lXt -lXpm -lX11
+
+ CC = gcc
+@@ -19,32 +19,33 @@
+
+ # --- Compile the programs
+
+-test_encoding: test_encoding.o ../libXawPlus.a
+- $(CC) -o test_encoding $(LIB_PATH) test_encoding.o ../libXawPlus.a $(LIBRARIES)
++test_encoding: test_encoding.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_encoding $(LIB_PATH) test_encoding.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_encoding.o:test_encoding.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_encoding.c
+
+-test_pixmap: test_pixmap.o ../libXawPlus.a
+- $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o ../libXawPlus.a $(LIBRARIES)
++test_pixmap: test_pixmap.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_pixmap.o: test_pixmap.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_pixmap.c
+
+-test_scrbar: test_scrbar.o ../libXawPlus.a
+- $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o ../libXawPlus.a $(LIBRARIES)
++test_scrbar: test_scrbar.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_scrbar.o: test_scrbar.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_scrbar.c
+
+-test_menu: test_menu.o ../libXawPlus.a
+- $(CC) -o test_menu $(LIB_PATH) test_menu.o ../libXawPlus.a $(LIBRARIES)
++test_menu: test_menu.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_menu $(LIB_PATH) test_menu.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_menu.o: test_menu.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_menu.c
+
+-
+ # --- Clean up
++
++.PHONY: clean
+
+ clean:
+ rm -f *.o $(PROGS)