summaryrefslogtreecommitdiff
path: root/x11-fm/emelfm2
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-10 03:53:42 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-10 03:53:42 +0000
commitff5be01f384ee59baa3618fd1125e7693a19d2fd (patch)
tree7eff2e05e087fc0dea875f59fac8cc3a9d7b8fe6 /x11-fm/emelfm2
parent- Update to 0.9.10.2 (diff)
- Update to 0.1.8
PR: ports/101614 Submitted by: Marcus von Appen <mva at sysfault.org> (maintainer)
Diffstat (limited to 'x11-fm/emelfm2')
-rw-r--r--x11-fm/emelfm2/Makefile4
-rw-r--r--x11-fm/emelfm2/distinfo6
-rw-r--r--x11-fm/emelfm2/files/patch-Makefile29
-rw-r--r--x11-fm/emelfm2/files/patch-Makefile.config15
4 files changed, 38 insertions, 16 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index 7da239ddbd79..c96fd0351983 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= emelfm2
-PORTVERSION= 0.1.7
+PORTVERSION= 0.1.8
CATEGORIES= x11-fm
MASTER_SITES= http://www.emelfm2.net/rel/ \
${MASTER_SITE_LOCAL}
@@ -23,6 +23,7 @@ INSTALLS_SHLIB= yes
INSTALL_TARGET= install install_i18n
MAKE_ENV= CC=${CC} LDFLAGS="${LDFLAGS}" DOC_DIR="${DOCSDIR}"
+MAN1= emelfm2.1
.include <bsd.port.pre.mk>
@@ -31,3 +32,4 @@ USE_GCC= 3.4
.endif
.include <bsd.port.post.mk>
+
diff --git a/x11-fm/emelfm2/distinfo b/x11-fm/emelfm2/distinfo
index d8e8824c5e36..f1f498c24f0c 100644
--- a/x11-fm/emelfm2/distinfo
+++ b/x11-fm/emelfm2/distinfo
@@ -1,3 +1,3 @@
-MD5 (emelfm2-0.1.7.tar.gz) = c4d1e2a539e165e8b0e5f9b0f3c3b215
-SHA256 (emelfm2-0.1.7.tar.gz) = 91d457239464b9f5a441ecda6ebc2f1307cfd08fd1d450af33e9ec7ea7e7d2c1
-SIZE (emelfm2-0.1.7.tar.gz) = 786129
+MD5 (emelfm2-0.1.8.tar.gz) = 3322a69e378fccb38272d0dd6d7c2f3e
+SHA256 (emelfm2-0.1.8.tar.gz) = 5bf8c94eefaa0683eae75278b314f0a469e229e232fbf6c934e170d14ab5faa8
+SIZE (emelfm2-0.1.8.tar.gz) = 850801
diff --git a/x11-fm/emelfm2/files/patch-Makefile b/x11-fm/emelfm2/files/patch-Makefile
index d857c533e5ef..a5f06629858e 100644
--- a/x11-fm/emelfm2/files/patch-Makefile
+++ b/x11-fm/emelfm2/files/patch-Makefile
@@ -1,17 +1,34 @@
---- Makefile.orig Tue Sep 13 02:06:53 2005
-+++ Makefile Wed Sep 14 19:42:41 2005
-@@ -124,10 +124,10 @@
+--- Makefile.orig Thu Jul 27 02:20:13 2006
++++ Makefile Mon Aug 7 23:26:10 2006
+@@ -57,7 +57,7 @@
+ endif
+ ICON_DIR ?= $(PREFIX)/share/pixmaps/$(TARGET)/
+ LOCALE_DIR ?= $(PREFIX)/share/locale/
+-MAN_DIR ?= $(PREFIX)/share/man/man1/
++MAN_DIR ?= $(PREFIX)/man/man1/
+
+ OBJECTS_DIR = objs
+ # object directories that have to be created
+@@ -148,10 +148,10 @@
ifeq ($(USE_FAM),1)
- lLDFLAGS += -lfam
+ lLIBS += -lfam
endif
-ifeq ($(OPSY),FreeBSD)
- OSREL = $(shell sysctl -n kern.osreldate)
-- lLDFLAGS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
+- lLIBS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
-endif
+#ifeq ($(OPSY),FreeBSD)
+# OSREL = $(shell sysctl -n kern.osreldate)
-+# lLDFLAGS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
++# lLIBS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
+#endif
.PHONY: all plugins install install_plugins uninstall uninstall_plugins doc \
clean deps marshals gettext i18n install_i18n uninstall_i18n \
+@@ -176,7 +176,6 @@
+ done
+ @install -d $(MAN_DIR)
+ @install -m 644 docs/$(TARGET).1 $(MAN_DIR);
+- @bzip2 -f $(MAN_DIR)$(TARGET).1;
+
+ ifeq ($(XGD_INTEGRATION), 1)
+ @install -d $(XGD_DESKTOP_DIR)
diff --git a/x11-fm/emelfm2/files/patch-Makefile.config b/x11-fm/emelfm2/files/patch-Makefile.config
index ea79cddbbd87..e7dc41bc0294 100644
--- a/x11-fm/emelfm2/files/patch-Makefile.config
+++ b/x11-fm/emelfm2/files/patch-Makefile.config
@@ -1,11 +1,14 @@
---- Makefile.config.orig Mon Nov 21 15:13:08 2005
-+++ Makefile.config Mon Nov 21 15:13:50 2005
-@@ -91,7 +91,7 @@
+--- Makefile.config.orig Mon Aug 7 22:58:41 2006
++++ Makefile.config Mon Aug 7 22:58:54 2006
+@@ -83,9 +83,9 @@
+ ifeq ($(strip $(CFLAGS)),)
+ ifeq ($(DEBUG), 1)
#CFLAGS = -Wall -Wextra -Wno-unused -Winline
- CFLAGS = -Wall -Winline
+-CFLAGS = -Wall -Winline
++CFLAGS ?= -Wall -Winline
else
-CFLAGS = -O2 -Wall
-+CFLAGS ?= -Wall
- #CFLAGS = -O3 -Wall -march=athlon-tbird -mtune=athlon-tbird
++CFLAGS ?= -O2 -Wall
+ #CFLAGS = -O3 -Wall -march=athlon-tbird -mtune=athlon-tbird
#CFLAGS = -O3 -Wall -march=pentium -mtune=pentium4
endif