summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 12:57:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 12:57:52 +0000
commita3c383f62d926c2ce3af35bbf3af92749150b751 (patch)
treea8d71bac10848d17da20b6cb390fa707b012c9f8 /www
parent[MAINTAINER] ports net/openldap2[012]-server: use RC_SUBR, miscellaneous impr... (diff)
[orphaned ports]: use USE_MYSQL for various orphaned ports.
Make these ports use USE_MYSQL: * databases/dbconnect * net/netsaint * www/mod_mp3 * www/mod_mylo * www/phpnuke * www/postnuke * www/udmsearch * mail/courier PR: ports/56029 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'www')
-rw-r--r--www/mod_mp3/Makefile2
-rw-r--r--www/mod_mylo/Makefile3
-rw-r--r--www/phpnuke/Makefile3
-rw-r--r--www/postnuke/Makefile3
-rw-r--r--www/udmsearch/Makefile3
5 files changed, 8 insertions, 6 deletions
diff --git a/www/mod_mp3/Makefile b/www/mod_mp3/Makefile
index 6ace2f4e7907..28478dfae175 100644
--- a/www/mod_mp3/Makefile
+++ b/www/mod_mp3/Makefile
@@ -27,7 +27,7 @@ APACHE_PORT?= ${PORTSDIR}/www/apache13
DOCS= ChangeLog README TODO faq.html
.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= YES
CONFIGURE_ARGS+= --with-mysql
.endif
diff --git a/www/mod_mylo/Makefile b/www/mod_mylo/Makefile
index 821964c0b237..d5032a7e3bdf 100644
--- a/www/mod_mylo/Makefile
+++ b/www/mod_mylo/Makefile
@@ -16,7 +16,8 @@ COMMENT= An Apache module to make Apache log to MySQL
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+USE_MYSQL= YES
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/www/phpnuke/Makefile b/www/phpnuke/Makefile
index 2ee418824cf1..c093e6d353d4 100644
--- a/www/phpnuke/Makefile
+++ b/www/phpnuke/Makefile
@@ -15,13 +15,14 @@ DISTNAME= PHP-Nuke-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An automated website package to distribute and manage content
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.if defined(WITH_PHP3)
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
+USE_MYSQL= yes
+
NO_BUILD= yes
NO_WRKSUBDIR= yes
DOCS= ADDONS-MODULES BLOCKS CHANGES README TODO
diff --git a/www/postnuke/Makefile b/www/postnuke/Makefile
index bc266d748432..c979e3c09b56 100644
--- a/www/postnuke/Makefile
+++ b/www/postnuke/Makefile
@@ -16,9 +16,10 @@ DISTNAME= Rogue_714
MAINTAINER= ports@FreeBSD.org
COMMENT= An automated website package to distribute and manage content
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:${PORTSDIR}/devel/pear-PEAR
+USE_MYSQL= YES
+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/pn_714
NO_WRKSUBDIR= yes
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index c2958324bb67..2ad04f582055 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -37,8 +37,7 @@ CONFIGURE_ARGS+= --with-msql=${LOCALBASE}
.else
# default to mysql
-
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= YES
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
.if !defined(WITH_MYSQL)