summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-04 20:01:05 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-04 20:01:05 +0000
commit9f7e7e1326e79bd8e12c1f04deb511f02f41b2f2 (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /www
parentRe-add the missing CFLAGS and LDFLAGS. (diff)
Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.
It's value is "--with-libiconv-prefix=/usr/local" for systems before 100043 with ports libiconv and to use at systems post 100043 with base iconv it's value is "" (NULL). Co-authors: bapt, madpilot and bsam (me)
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile2
-rw-r--r--www/elinks/Makefile2
-rw-r--r--www/lynx-current/Makefile2
-rw-r--r--www/lynx/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 687ee0dd4d2c..8bc418f3bdc2 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -49,7 +49,7 @@ post-install:
.if ${PORT_OPTIONS:MNLS}
USES= gettext iconv
-CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE}
LANGS=en@quot es it
.for lang in ${LANGS}
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index 4de52607d229..119cb9cc71f3 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -191,7 +191,7 @@ CONFIGURE_ARGS+= --disable-sm-scripting --without-spidermonkey
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
.endif
#
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 2fe4cdeb3f57..aa8f11c793ee 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --with-zlib --libdir="${L_LIB}" \
--enable-idna \
--enable-ipv6 \
--with-mime-libdir=${PREFIX}/etc \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-screen=ncursesw \
--with-ssl=${OPENSSLBASE}
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 8303d6bdbc49..ddaa43edbdfe 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS='@comment '
.else
USES+= gettext iconv
-CONFIGURE_ARGS+=--enable-nls --with-libiconv-prefix="${LOCALBASE}"
+CONFIGURE_ARGS+=--enable-nls ${ICONV_CONFIGURE_ARG}
PLIST_SUB+= NLS=''
.endif