summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2001-06-16 08:59:04 +0000
committerMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2001-06-16 08:59:04 +0000
commit7b304aa9dea3f06b204a49144e54644ca541da4f (patch)
tree4f20076a90a8d5bf046ce946c5b78c6ba7ebf165 /www
parentPut dummy files in the empty directories so they are surely packed. (diff)
use wc command for check file size.
slower but more portable than using ls
Diffstat (limited to 'www')
-rw-r--r--www/thumbnail_index/Makefile1
-rw-r--r--www/thumbnail_index/files/patch-ab11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/thumbnail_index/Makefile b/www/thumbnail_index/Makefile
index 05acd4354b15..0c0a2f8c37a3 100644
--- a/www/thumbnail_index/Makefile
+++ b/www/thumbnail_index/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thumbnail_index
PORTVERSION= 1998.08.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/thumbnail_index/
DISTNAME= ${PORTNAME}_10aug98
diff --git a/www/thumbnail_index/files/patch-ab b/www/thumbnail_index/files/patch-ab
new file mode 100644
index 000000000000..deb32a163ea1
--- /dev/null
+++ b/www/thumbnail_index/files/patch-ab
@@ -0,0 +1,11 @@
+--- thumbnail_index.orig Tue Aug 11 03:51:55 1998
++++ thumbnail_index Sat Jun 16 17:56:31 2001
+@@ -248,7 +248,7 @@
+ EOF
+ )
+ fi
+- kb=`ls -l "$file" | awk '{print int(($4+1023)/1024)}'`
++ kb=`wc -c < "$file" | awk '{print int(($1+1023)/1024)}'`
+ echo "<TD ALIGN=CENTER><TABLE><TR><TD ALIGN=CENTER><A HREF=\"$file\"><IMG BORDER=0 WIDTH=20 HEIGHT=22 SRC=\"$subdir/.file.gif\"></A></TD></TR><TR><TD ALIGN=CENTER><SMALL><A HREF=\"$file\">$file</A></SMALL></TD></TR><TR><TD ALIGN=CENTER><SMALL>${kb}K</SMALL></TD></TR></TABLE></TD>"
+ fi
+ ;;