summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 03:14:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 03:14:55 +0000
commit2e2a921591f677d4921b4e1dd49fe2b5a0e3ded3 (patch)
tree8e6cbbf115e00b92e4cc6ebbbd83d8b0cc71180a /www
parentAdd moftpd 1.1.6. (diff)
Borrow from the OpenLDAP ports, and refuse to build if bind has been
installed with PORT_REPLACES_BASE_BIND defined. PR: 61756 Obtained from: OpenLDAP ports
Diffstat (limited to 'www')
-rw-r--r--www/firefox-devel/Makefile6
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/firefox10/Makefile6
-rw-r--r--www/firefox15/Makefile6
-rw-r--r--www/firefox3-devel/Makefile6
-rw-r--r--www/firefox35/Makefile6
-rw-r--r--www/firefox36/Makefile6
-rw-r--r--www/flock/Makefile6
-rw-r--r--www/mozilla-devel/Makefile6
-rw-r--r--www/mozilla/Makefile6
-rw-r--r--www/seamonkey/Makefile6
-rw-r--r--www/seamonkey2/Makefile6
13 files changed, 78 insertions, 0 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/flock/Makefile b/www/flock/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 703e78463c4e..0a330a0387b3 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -229,6 +229,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}