summaryrefslogtreecommitdiff
path: root/www/wwwoffle/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-05-19 08:44:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-05-19 08:44:38 +0000
commit0181081672c84e9f1031d47820172ef398411c81 (patch)
treed0d4a970a1f31366f37399f9e38801651b50daf8 /www/wwwoffle/Makefile
parentUpdate to 9.1 (diff)
Several fixes and improvements:
"The wwwoffle port has "/var/spool/wwwoffle" hardcoded as the path for the spool, both in the Makefile and PLIST. Even if a user overrides this in Makefile they may not know PLIST needs changing. Also, the installation attempted to change the ownership of some files to root:wheel, this changes that to ${BINOWN}:${BINGRP}. This means one less warning message while testing the port as a non-root user if nothing else." PR: 18372 Submitted by: maintainer
Diffstat (limited to 'www/wwwoffle/Makefile')
-rw-r--r--www/wwwoffle/Makefile30
1 files changed, 25 insertions, 5 deletions
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index 7a3298083f29..953aebdf05fe 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -17,21 +17,41 @@ MAINTAINER= ben@scientia.demon.co.uk
USE_PERL5= yes
-MAN1= wwwoffle.1
-MAN5= wwwoffle.conf.5
-MAN8= wwwoffled.8
+# $SPOOL seems like a common name which could be used for other things, so
+# use $WWWOFFLE_SPOOL as the overriding setting.
+WWWOFFLE_SPOOL?= /var/spool
+SPOOL= ${WWWOFFLE_SPOOL}
-SPOOL= /var/spool
+PLIST_SUB+= SPOOL=${SPOOL}
MAKE_ENV+= SPOOL="${SPOOL}" \
+ BINOWN="${BINOWN}" \
+ BINGRP="${BINGRP}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_MAN="${INSTALL_MAN}"
+MAN1= wwwoffle.1
+MAN5= wwwoffle.conf.5
+MAN8= wwwoffled.8
+
+.if ${SPOOL} != "/var/spool"
+# If using a non-standard spool, change all the documentation (and anything
+# else) to reflect that.
+PKGMESSAGE=${WRKDIR}/MESSAGE
+
+do-configure:
+ @find ${WRKSRC} | xargs ${CHMOD} u+w
+ @find ${WRKSRC} -type f | \
+ xargs perl -pi -e 's@/var/spool/wwwoffle@${SPOOL}/wwwoffle@g'
+ @${SED} 's@/var/spool/wwwoffle@${SPOOL}/wwwoffle@g' \
+ ${PKGDIR}/MESSAGE > ${PKGMESSAGE}
+.endif
+
post-install:
@${MKDIR} ${SPOOL}/wwwoffle
@${INSTALL_SCRIPT} ${WRKSRC}/upgrade-config.pl ${SPOOL}/wwwoffle
- @${INSTALL_SCRIPT} ${FILESDIR}/wwwoffled.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/wwwoffled.sh ${PREFIX}/etc/rc.d/wwwoffled.sh.sample
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>