summaryrefslogtreecommitdiff
path: root/www/tdiary/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-09 02:48:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-09 02:48:11 +0000
commitbde98a7340772ad78b1e327fb5e110496d26229f (patch)
tree3daf3121ac83885be2fcbb2f11112df43e615ef6 /www/tdiary/Makefile
parentUpdate to 0.2.8. (diff)
Fix a security related problem in tDiary 1.5.6, see
http://www.tdiary.org/20031119.html (Japanese-language) for details. It only happened in the following case: * "@secure = true" in setting file (tdiary.conf) * output_rdf.rb or tb-send.rb by plugin choice PR: ports/59451 Submitted by: Fumihiko Kimura <jfkimura@yahoo.co.jp> (maintainer)
Diffstat (limited to 'www/tdiary/Makefile')
-rw-r--r--www/tdiary/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index 13383966da2f..fa00ee3b640c 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tdiary
PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES?= www ruby
MASTER_SITES= \
${MASTER_SITE_SOURCEFORGE} \
@@ -70,6 +71,7 @@ do-install:
post-install:
@cd ${WRKSRC} && ${FIND} . -type f -o -type l | ${SED} -e 's,^\.,${TDIARYDIR:S|${LOCALBASE}/||},' >> ${TMPPLIST}
@cd ${WRKSRC} && ${FIND} . -type d -depth | ${SED} -e 's,^\.,@dirrm ${TDIARYDIR:S|${LOCALBASE}/||},' >> ${TMPPLIST}
- @${SED} -e "s,%%EXAMPLESDIR%%,${EXAMPLESDIR},g" ${PKGMESSAGE}
+ @${SED} -e 's|%%EXAMPLESDIR%%|${EXAMPLESDIR}|' < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>