summaryrefslogtreecommitdiff
path: root/www/smarty/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-09-26 20:43:21 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-09-26 20:43:21 +0000
commitef71cdb328aeada70e198b3559179d3b70c4b091 (patch)
tree5daa37cd01b67c3f0b571969a256257623f3e52e /www/smarty/Makefile
parent- Renamed from www/smarty to www/smarty2 to prepare for addition of (diff)
- Forgot to commit the deleted www/smarty directory after the rename
Diffstat (limited to 'www/smarty/Makefile')
-rw-r--r--www/smarty/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
deleted file mode 100644
index e0a8898daeb5..000000000000
--- a/www/smarty/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# New ports collection makefile for: smarty
-# Date created: 10 March 2002
-# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
-#
-# $FreeBSD$
-#
-
-PORTNAME= smarty
-PORTVERSION= 2.6.26
-CATEGORIES= www
-MASTER_SITES= http://www.smarty.net/distributions/ \
- http://www.smarty.net/distributions/manual/en/:manual
-DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
-.if !defined(NOPORTDOCS)
-DISTFILES+= Smarty-${DOCSVERSION}-docs${EXTRACT_SUFX}:manual
-.endif
-
-MAINTAINER= glarkin@FreeBSD.org
-COMMENT= The PHP compiling template engine
-
-DOCSVERSION= 2.6.14
-
-WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
-
-NO_BUILD= yes
-USE_PHP= pcre
-WANT_PHP_WEB= yes
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
-
-do-install:
- @${MKDIR} ${DATADIR}
-.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
- @${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
-.endfor
- @${MKDIR} ${DATADIR}/internals
- @${INSTALL_DATA} ${WRKSRC}/libs/internals/* ${DATADIR}/internals
- @${MKDIR} ${DATADIR}/plugins
- @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in BUGS FAQ INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
-.endfor
- @${MKDIR} ${DOCSDIR}/manual
- @cd ${WRKDIR}/manual && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>