summaryrefslogtreecommitdiff
path: root/www/servlet-api
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-11 20:12:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-11 20:12:09 +0000
commit2c71c991a0ce01f2f2d31e259846d15da020b8eb (patch)
treed0a24bcb68b84c6fded767f239dc44962663ef1d /www/servlet-api
parent- Use termios.h when available (diff)
- Update to 2.5
- Pass maintainership to submitter PR: 111394 Submitted by: Nemo Liu<nemoliu@gmail.com>
Diffstat (limited to 'www/servlet-api')
-rw-r--r--www/servlet-api/Makefile12
-rw-r--r--www/servlet-api/distinfo6
-rw-r--r--www/servlet-api/pkg-descr1
3 files changed, 11 insertions, 8 deletions
diff --git a/www/servlet-api/Makefile b/www/servlet-api/Makefile
index 10aa41381f52..89f05c62810b 100644
--- a/www/servlet-api/Makefile
+++ b/www/servlet-api/Makefile
@@ -6,22 +6,24 @@
#
PORTNAME= servlet-api
-PORTVERSION= 2.4
+PORTVERSION= 2.5
CATEGORIES= www java
-MASTER_SITES= http://www.ibiblio.org/maven/servletapi/jars/
+MASTER_SITES= http://fisheye5.cenqua.com/browse/~raw,r=1.1.1.3/glassfish/repo/javax.servlet/jars/
EXTRACT_SUFX= .jar
EXTRACT_ONLY= # empty
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemoliu@gmail.com
COMMENT= The Servlet API
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
do-install:
- ${INSTALL_DATA} ${_DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${_DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
.include <bsd.port.mk>
diff --git a/www/servlet-api/distinfo b/www/servlet-api/distinfo
index 465473ed04ec..2204ab7b4f99 100644
--- a/www/servlet-api/distinfo
+++ b/www/servlet-api/distinfo
@@ -1,3 +1,3 @@
-MD5 (servlet-api-2.4.jar) = f6cf3fde0b992589ed3d87fa9674015f
-SHA256 (servlet-api-2.4.jar) = 243f8b5577f59bffdd30fd15cc25fc13004a6b08773a61cc32e48726c3633b7c
-SIZE (servlet-api-2.4.jar) = 97693
+MD5 (servlet-api-2.5.jar) = 116fc16f3f700d756a57a2b8ea7c1044
+SHA256 (servlet-api-2.5.jar) = 433ce67a1436573a4b7e5e4db5b4b09d670dd5371e45e769ce50a45350161057
+SIZE (servlet-api-2.5.jar) = 105334
diff --git a/www/servlet-api/pkg-descr b/www/servlet-api/pkg-descr
index 91b722e9b319..9b1c5b3b4a72 100644
--- a/www/servlet-api/pkg-descr
+++ b/www/servlet-api/pkg-descr
@@ -7,3 +7,4 @@ runs on the server side -- without a face. Java servlets make many Web
applications possible.
WWW: http://java.sun.com/products/servlet/
+WWW: http://fisheye5.cenqua.com/browse/glassfish/repo/javax.servlet