summaryrefslogtreecommitdiff
path: root/www/roxen/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 17:55:51 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 17:55:51 +0000
commit9f8a743a15df877ad436111b6fc87c7fa5fa7c06 (patch)
tree3325e3b11a3bf61ca44950cb8899f8d35a43a6cf /www/roxen/Makefile
parentAdd sl (diff)
* Corrected Makefile with respect to ${PREFIX}
* Updated pkg/PLIST * Fixed typo in pkg/DESCR PR: 13829 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> Approved by: maintainer
Diffstat (limited to 'www/roxen/Makefile')
-rw-r--r--www/roxen/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/www/roxen/Makefile b/www/roxen/Makefile
index 6ebbf3d23d10..c4f2ee6a17ef 100644
--- a/www/roxen/Makefile
+++ b/www/roxen/Makefile
@@ -19,8 +19,10 @@ GNU_CONFIGURE= yes
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/roxen.sh
post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/roxen.sh > \
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/roxen.sh.in > \
${WRKDIR}/roxen.sh
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/MESSAGE.in > \
+ ${PKGDIR}/MESSAGE
do-configure:
@(cd ${WRKSRC}; \
@@ -29,18 +31,8 @@ do-configure:
post-install:
@if [ ! -f ${STARTUP_SCRIPT} ]; then \
${ECHO} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${INSTALL_SCRIPT} ${FILESDIR}/roxen.sh ${STARTUP_SCRIPT}; \
+ ${INSTALL_SCRIPT} ${WRKDIR}/roxen.sh ${STARTUP_SCRIPT}; \
fi
- @${ECHO_MSG} "Installation of Roxen Challenger finished!"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Now perform the following steps to initialize"
- @${ECHO_MSG} "the webserver."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "# cd ${PREFIX}/roxen/server/"
- @${ECHO_MSG} "# ./install"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Then follow the instructions. For further"
- @${ECHO_MSG} "documentation read http://roxen.com/documentation/"
- @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>