summaryrefslogtreecommitdiff
path: root/www/raqdevil
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-03 22:27:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-03 22:27:34 +0000
commit1a5539c0641be332452c300ebb3e82bdf01d2595 (patch)
treeb68edf0d05fb2010e46e72f21df8dd228a207a93 /www/raqdevil
parentFix pkg-plist (diff)
Properly do sendmail-sasl checking
I spoke with dinoex@ about the correct thing to do regarding the dependency on the sendmail-sasl port. Apparently there is a variable ``SENDMAIL_MILTER_PORT'' that is used by milters to determine which version of sendmail they should depend on -- solving almost the exact issue we have with the RAQdevil port. Attached is a patch that removes the pkg_info construction and uses the SENDMAIL_MILTER_PORT instead... I think it is a lot cleaner at least to read. What do you think? Submitted by: Devon O'Dell <dodell@offmyserver.com>
Diffstat (limited to 'www/raqdevil')
-rw-r--r--www/raqdevil/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/www/raqdevil/Makefile b/www/raqdevil/Makefile
index 2a2cee3b02f6..b4570d51408e 100644
--- a/www/raqdevil/Makefile
+++ b/www/raqdevil/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.raqdevil.com/
MAINTAINER= dodell@offmyserver.com
COMMENT= A port of the Sun Cobalt RaQ550 software to FreeBSD
-RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/sendmail-sasl \
+RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT} \
${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/mach/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
${SITE_PERL}/mach/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
@@ -47,18 +47,23 @@ LDCONFIG_DIRS= ${PREFIX}/raqdevil/lib
.include <bsd.port.pre.mk>
+.if !defined(SENDMAIL_MILTER_PORT)
+SENDMAIL_MILTER_PORT?= sendmail-sasl
+.else
+.if ${SENDMAIL_MILTER_PORT} != "sendmail-sasl"
+pre-everything::
+ @${ECHO_MSG} "SENDMAIL_MILTER_PORT=${SENDMAIL_MILTER_PORT}
+ @${ECHO_MSG} "RAQdevil makes use of the sendmail-sasl metaport. Please set"
+ @${ECHO_MSG} "SENDMAIL_MILTER_PORT=sendmail-sasl in /etc/make.conf"
+ @${FALSE}
+.endif
+.endif
+
pre-extract:
.if !defined(PACKAGE_BUILDING)
@${SH} ${FILESDIR}/warning
.endif
-pre-configure:
- @if [ -n "`${PKG_INFO} -xI '^sendmail+tls+sasl*' 2> /dev/null`" ]; then \
- ${ECHO_CMD} "${PKGNAME}: sendmail with sasl support is required for RAQdevil to properly function."; \
- ${ECHO_CMD} "Please install mail/sendmail-sasl." \
- ${FALSE}; \
- fi
-
post-extract:
.if !defined(PACKAGE_BUILDING)
${CC} -o ${WRKSRC}/rdqchk ${FILESDIR}/rdqchk.c