summaryrefslogtreecommitdiff
path: root/www/quanta/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-05-20 03:54:48 +0000
committerWill Andrews <will@FreeBSD.org>2000-05-20 03:54:48 +0000
commitfee44ad6a31787ef9088c1e79d5c975fa7594bf1 (patch)
tree06905c20b6e9bb86dbf0834fbaf6c8aa498a93c9 /www/quanta/Makefile
parentUpdate to 1.5 patch1 (diff)
Add Quanta+, a GUI HTML editor that bears resemblance to KDevelop. I had
to use HAS_CONFIGURE instead of GNU_CONFIGURE because for some reason it kept thinking bsd.port.mk is giving it too many arguments. So I overrode this behavior with CONFIGURE_ARGS.
Diffstat (limited to 'www/quanta/Makefile')
-rw-r--r--www/quanta/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/quanta/Makefile b/www/quanta/Makefile
new file mode 100644
index 000000000000..c7d373b4ccd2
--- /dev/null
+++ b/www/quanta/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Quanta+
+# Date created: 19 May 2000
+# Whom: Will Andrews <will@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quanta
+PORTVERSION= 1.0.2
+CATEGORIES= www kde
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/quanta/ \
+ http://download.sourceforge.net/quanta/
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= kdeui.3:${PORTSDIR}/x11/kdelibs11/
+
+USE_BZIP2= yes
+USE_QT= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_GMAKE= yes
+
+.include <bsd.port.mk>