summaryrefslogtreecommitdiff
path: root/www/py-prewikka/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-27 01:21:30 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-27 01:21:30 +0000
commitf6e4fe43e7c2e73bb3e7b086d23474bed4d3e2b4 (patch)
treeaa4fe1efbf037710e51652d288e721251351ea71 /www/py-prewikka/Makefile
parent- Added WITH_PRELUDE option. Also added a patch to fix the 'missing prelude.h' (diff)
- Update to 0.9.8
prewikka 0.9.8 Changelog: - Save/load user configuration when using CGI authentication mode (#181). - Show Prewikka version in the About page (#177). - Use Python logging facility (available backend: stderr, file, smtp, syslog), multiple simultaneous handler supported (#113). - Fix anonymous authentication. - Fix external process going into zombie state (#178). - Fix sqlite schema (#180). - Display correct alertident for invalid CorrelationAlert analyzerid/messageid pair. - prewikka-httpd should now log the source address. - Thread safety fixes. PR: ports/105807 Submitted by: maintainer (Robin Gruyters)
Diffstat (limited to 'www/py-prewikka/Makefile')
-rw-r--r--www/py-prewikka/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/py-prewikka/Makefile b/www/py-prewikka/Makefile
index 1819fe26da75..5e514bb6b206 100644
--- a/www/py-prewikka/Makefile
+++ b/www/py-prewikka/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= prewikka
-PORTVERSION= 0.9.7.1
-PORTREVISION= 1
+PORTVERSION= 0.9.8
CATEGORIES= www security python
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -17,7 +16,7 @@ MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Frontend for the Prelude IDS
BUILD_DEPENDS= cheetah-compile:${PORTSDIR}/devel/py-cheetah
-LIB_DEPENDS= prelude.[6-?]:${PORTSDIR}/security/libprelude \
+LIB_DEPENDS= prelude.10:${PORTSDIR}/security/libprelude \
preludedb.4:${PORTSDIR}/security/libpreludedb
USE_PYTHON= 2.3+
@@ -28,4 +27,10 @@ post-patch:
${REINPLACE_CMD} 's,conf/prewikka.conf,conf/prewikka.conf-dist,' \
${WRKSRC}/setup.py
+post-install:
+ @if [ ! -f ${PREFIX}/etc/prewikka/prewikka.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/prewikka/prewikka.conf-dist \
+ ${PREFIX}/etc/prewikka/prewikka.conf ; \
+ fi
+
.include <bsd.port.mk>