summaryrefslogtreecommitdiff
path: root/www/py-prewikka/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-15 22:22:37 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-15 22:22:37 +0000
commit89fe9269e119455b22fdaedd92f69187a2321e44 (patch)
tree4f12744fd7400245025a2fec543c64eaad413edb /www/py-prewikka/Makefile
parentCovert gnomedepends.py from Python 2 to Python 3. (diff)
Update Prelude-IDS ports to 1.0.1 release
security/libprelude: - Remove BROKEN, update to version 1.0.1 [1] - Add missing deps, port requires pkg-config during build security/libpreludedb: - Update to version 1.0.1p1 - Add missing deps - Make options deterministic and not dependent on what's installed security/prelude-lml: - Update to version 1.0.1 - Add missing deps, port requires pkg-config during build - Convert to OptionsNG security/prelude-manager: - Update to version 1.0.2 - Add missing deps, port requires pkg-config during build - Convert to OptionsNG, remove PRELUDEDB option - it can't be turned off by CONFIGURE_ARGS, package links to preludedb at all times if available security/pflogger: - Bump PORTREVISION, libprelude ABI version changed www/py-prewikka: - Update to version 1.0.1p1 - Convert to OptionsNG - Sort plist PR: 172056 [1] Submitted by: KATO Tsuguru <tkato432@yahoo.com> [1]
Diffstat (limited to 'www/py-prewikka/Makefile')
-rw-r--r--www/py-prewikka/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/www/py-prewikka/Makefile b/www/py-prewikka/Makefile
index 7d6d4812b793..9cd87dc6e137 100644
--- a/www/py-prewikka/Makefile
+++ b/www/py-prewikka/Makefile
@@ -1,29 +1,25 @@
-# New ports collection makefile for: prewikka
-# Date created: 2006-03-13
-# Whom: Robin Gruyters <r.gruyters@yirdis.nl>
-#
+# Created by: Robin Gruyters <r.gruyters@yirdis.nl>
# $FreeBSD$
-#
PORTNAME= prewikka
-PORTVERSION= 0.9.17.1
-PORTREVISION= 2
+PORTVERSION= 1.0.1p1
CATEGORIES= www security python
-MASTER_SITES= http://www.prelude-technologies.com/download/releases/${PORTNAME}/
-
+MASTER_SITES= https://www.prelude-ids.org/attachments/download/286/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Frontend for the Prelude IDS
BUILD_DEPENDS= cheetah-compile:${PORTSDIR}/devel/py-cheetah
-LIB_DEPENDS= prelude.20:${PORTSDIR}/security/libprelude \
- preludedb.4:${PORTSDIR}/security/libpreludedb
+LIB_DEPENDS= prelude:${PORTSDIR}/security/libprelude \
+ preludedb:${PORTSDIR}/security/libpreludedb
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -34,7 +30,7 @@ post-patch:
${MV} ${WRKSRC}/conf/prewikka.conf ${WRKSRC}/conf/prewikka.conf-dist
${REINPLACE_CMD} 's,conf/prewikka.conf,conf/prewikka.conf-dist,' \
${WRKSRC}/setup.py
-.if defined(WITHOUT_NLS)
+.if !${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} 's,\(.*self.data_files.extend(self._compile_po_files())\),#\1,' \
${WRKSRC}/setup.py
.endif