summaryrefslogtreecommitdiff
path: root/www/plugger
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-12 07:49:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-12 07:49:47 +0000
commitde80d22edbe64b5b569c1564e3feed2c37f3f018 (patch)
tree976cafdada1bafc7f245bbb4dbc8cd5b74180e38 /www/plugger
parentUpdate to xmlenc 0.41. (diff)
* Update to 5.0
* Helper applications will be farmed out to new ports PR: 62720 Submitted by: maintainer
Diffstat (limited to 'www/plugger')
-rw-r--r--www/plugger/Makefile125
-rw-r--r--www/plugger/distinfo4
-rw-r--r--www/plugger/files/patch-aa61
-rw-r--r--www/plugger/files/patch-plugger-controller.c11
-rw-r--r--www/plugger/files/patch-plugger-helper.c84
-rw-r--r--www/plugger/files/patch-pluggerrc159
-rw-r--r--www/plugger/pkg-install56
-rw-r--r--www/plugger/pkg-message36
-rw-r--r--www/plugger/pkg-message-mplayer24
-rw-r--r--www/plugger/pkg-plist9
10 files changed, 135 insertions, 434 deletions
diff --git a/www/plugger/Makefile b/www/plugger/Makefile
index b2156d157535..0a989b355e37 100644
--- a/www/plugger/Makefile
+++ b/www/plugger/Makefile
@@ -6,101 +6,82 @@
#
PORTNAME= plugger
-PORTVERSION= 4.0
-PORTREVISION= 4
+PORTVERSION= 5.0
CATEGORIES= www audio graphics multimedia
-MASTER_SITES= http://fredrik.hubbe.net/plugger/ \
- ${MASTER_SITE_NETSCAPE}
-MASTER_SITE_SUBDIR= sdk/plugin/unix
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unix-sdk-3.0b5.tar.Z
+MASTER_SITES= http://fredrik.hubbe.net/plugger/
MAINTAINER= coop9211@uidaho.edu
COMMENT= A multimedia front-end plugin for Mozilla or Opera
-RUN_DEPENDS= ${LOCALBASE}/bin/nspptview:${PORTSDIR}/textproc/xlhtml \
- ${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123 \
- ${LOCALBASE}/bin/sidplay:${PORTSDIR}/audio/sidplay \
- ${LOCALBASE}/bin/wavplay:${PORTSDIR}/audio/wavplay \
- ${LOCALBASE}/bin/xmp:${PORTSDIR}/audio/xmp \
- ${X11BASE}/bin/gqview:${PORTSDIR}/graphics/gqview \
- ${LOCALBASE}/bin/display:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/bin/timidity:${PORTSDIR}/audio/timidity++ \
- ${X11BASE}/bin/gv:${PORTSDIR}/print/gv \
- ${X11BASE}/bin/xanim:${PORTSDIR}/multimedia/xanim \
- ${LOCALBASE}/bin/acroread5:${PORTSDIR}/print/acroread5
-
USE_X_PREFIX= yes
USE_REINPLACE= yes
MAN7= plugger.7
-MANCOMPRESSED= no
ALL_TARGET= freebsd-elf
+PKGDEINSTALL= ${PKGINSTALL}
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/mplayer)
-WITH_MPLAYER = yes
-.endif
-
-.if exists(${LOCALBASE}/bin/mtvp)
-WITH_MTV = yes
-.endif
-
-.if exists(${X11BASE}/lib/libgnomeprintui-2-2.so.0)
-WITH_GNOME2 = yes
-.endif
-
-.if defined(WITH_MPLAYER)
-RUN_DEPENDS+= ${LOCALBASE}/bin/mplayer:${PORTSDIR}/multimedia/mplayer
-.endif
-
-.if defined(WITH_MTV)
-RUN_DEPENDS+= ${LOCALBASE}/bin/mtvp:${PORTSDIR}/multimedia/mtv
-.endif
-
-.if defined(WITH_GNOME2)
-RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric2 \
- ${X11BASE}/bin/abiword:${PORTSDIR}/editors/AbiWord2
-.else
-RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric
-.endif
-
-pre-extract:
-.if !defined(WITH_MPLAYER)
- @${ECHO_MSG} "Enable mplayer for AVI video by defining WITH_MPLAYER."
-.endif
-
-.if !defined(WITH_MTV)
- @${ECHO_MSG} "Enable mtvp for MPEG video by defining WITH_MTV."
-.endif
-
-.if !defined(WITH_GNOME2)
- @${ECHO_MSG} "Enable Gnome/2 AbiWord and Gnumeric by defining"
- @${ECHO_MSG} "WITH_GNOME2."
-.endif
-
post-patch:
- @${MV} ${WRKSRC}/plugger.c ${WRKSRC}/plugger.c.orig
- @${SED} \
- -e 's#/usr/local/#${PREFIX}/#' \
- ${WRKSRC}/plugger.c.orig > ${WRKSRC}/plugger.c
-# CC safeness
- @${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|g' \
+ ${WRKSRC}/plugger.c
+ @${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|g' \
+ -e 's|LD=gcc|LD=${CC}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/X11R6/|${X11BASE}|g' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
${PREFIX}/bin
@${MKDIR} ${PREFIX}/lib/browser_plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
+ ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger-controller \
+ ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
${PREFIX}/lib/browser_plugins/npplugger.so
+ @if [ -f ${PREFIX}/etc/pluggerrc-${PORTVERSION} ]; then \
+ ${MV} ${PREFIX}/etc/pluggerrc-${PORTVERSION} \
+ ${PREFIX}/etc/pluggerrc-${PORTVERSION}.old; \
+ fi
+ @${INSTALL_DATA} ${WRKSRC}/pluggerrc \
+ ${PREFIX}/etc/pluggerrc-${PORTVERSION}.sample
@${INSTALL_MAN} ${WRKSRC}/plugger.7 ${MANPREFIX}/man/man7
- @${INSTALL_DATA} ${WRKSRC}/pluggerrc ${PREFIX}/etc/pluggerrc.sample
- @${INSTALL_DATA} -b ${WRKSRC}/pluggerrc ${PREFIX}/etc
+
+local-install:
+ @${MKDIR} ${HOME}/.mozilla/plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
+ ${HOME}/.mozilla/plugins/npplugger.so
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
+ ${HOME}/.mozilla
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger-controller \
+ ${HOME}/.mozilla
+ @if [ -f ${HOME}/.mozilla/pluggerrc-${PORTVERSION} ]; then \
+ ${MV} ${HOME}/.mozilla/pluggerrc-${PORTVERSION} \
+ ${HOME}/.mozilla/pluggerrc-${PORTVERSION}.old; \
+ fi
+ @${INSTALL_DATA} ${WRKSRC}/pluggerrc \
+ ${HOME}/.mozilla/pluggerrc-${PORTVERSION}
+
+local-opera-install:
+ @${MKDIR} ${HOME}/.opera/plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
+ ${HOME}/.opera/plugins/npplugger.so
+ @${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
+ ${HOME}/.opera
+ @if [ -f ${HOME}/.opera/pluggerrc-${PORTVERSION} ]; then \
+ ${MV} ${HOME}/.opera/pluggerrc-${PORTVERSION} \
+ ${HOME}/.opera/pluggerrc-${PORTVERSION}.old; \
+ fi
+ @${INSTALL_DATA} ${WRKSRC}/pluggerrc \
+ ${HOME}/.opera/pluggerrc-${PORTVERSION}
post-install:
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
-.if defined(WITH_MPLAYER)
- @${CAT} ${PKGMESSAGE}-mplayer
-.endif
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/www/plugger/distinfo b/www/plugger/distinfo
index 181f3e28a1ea..8d8ed48bf5d8 100644
--- a/www/plugger/distinfo
+++ b/www/plugger/distinfo
@@ -1,2 +1,2 @@
-MD5 (plugger-4.0.tar.gz) = bf39c1405760183a01b8ec8fbfa6d430
-MD5 (unix-sdk-3.0b5.tar.Z) = 1e43785d5697c60937e8d6236e7d7d7e
+MD5 (plugger-5.0.tar.gz) = c2b263c7c34f759fb8b2e29b243b5ca1
+SIZE (plugger-5.0.tar.gz) = 55005
diff --git a/www/plugger/files/patch-aa b/www/plugger/files/patch-aa
deleted file mode 100644
index f4981fec1ab0..000000000000
--- a/www/plugger/files/patch-aa
+++ /dev/null
@@ -1,61 +0,0 @@
---- Makefile.orig Sun Mar 24 18:40:09 2002
-+++ Makefile Sun Mar 24 18:45:17 2002
-@@ -1,8 +1,8 @@
- # Where is your Plugin Source Development Kit from Netscape?
--SDK=/home/hubbe/src/PluginSDK30b5
-+SDK=../PluginSDK30b5
-
- # Where is your Xwindows located?
--X11=/usr/X11/
-+X11=${X11BASE}
-
- #
- # For building rpms
-@@ -10,15 +10,15 @@
-
- # You may want to change this to /usr/ on
- # some installations.
--prefix=/usr/local
-+prefix=${PREFIX}
-
- #
- #
- RPMDIR=/usr/src/RPM
-
- # Choose compiler
--CC=gcc
--LD=gcc
-+#CC=gcc
-+#LD=gcc
- BINFORMAT=bin
-
- any:
-@@ -32,7 +32,7 @@
- @echo ' make hp-cc - for HP-UX with cc'
- @echo ' make irix - for Irix'
- @echo ' make aix - for AIX >= 4.2'
-- @echo ' make freebsd - for FreeBSD 4.x'
-+ @echo ' make freebsd-elf - for FreeBSD 4.x'
-
- irix:
- make all CC=gcc XCFLAGS=-fpic LD=ld XLDFLAGS='-shared -n32'
-@@ -91,7 +91,7 @@
- BIN_FILES=plugger.so plugger-$(VERSION)
-
- DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" # -DDEBUG # -DPLUGIN_TRACE
--COMMON_CFLAGS=-O -I$(SDK)/include -I$(X11)/include -DXP_UNIX $(DEFINES)
-+COMMON_CFLAGS=-I$(SDK)/include -I$(X11)/include -DXP_UNIX $(DEFINES)
- COMMON_LDFLAGS=
- NORM_CFLAGS=
- NORM_LDFLAGS=
-@@ -100,8 +100,8 @@
- XLIBS=-lX11 -L$(X11)/lib
-
- LDSHARED=$(LD) $(XLDFLAGS)
--CFLAGS=$(COMMON_CFLAGS) $(NORM_CFLAGS)
--LDFLAGS=$(COMMON_LDFLAGS) $(NORM_LDFLAGS)
-+CFLAGS+=$(COMMON_CFLAGS) $(NORM_CFLAGS)
-+LDFLAGS+=$(COMMON_LDFLAGS) $(NORM_LDFLAGS)
- SHARED_CFLAGS=$(COMMON_CFLAGS) $(XCFLAGS)
-
- all: plugger.so plugger-$(VERSION)
diff --git a/www/plugger/files/patch-plugger-controller.c b/www/plugger/files/patch-plugger-controller.c
new file mode 100644
index 000000000000..656e178bed88
--- /dev/null
+++ b/www/plugger/files/patch-plugger-controller.c
@@ -0,0 +1,11 @@
+--- plugger-controller.c.old Wed Feb 11 16:22:04 2004
++++ plugger-controller.c Wed Feb 11 16:23:47 2004
+@@ -136,7 +136,7 @@
+ if(!pid)
+ {
+ char *cmd[4];
+- setpgrp();
++ setpgrp(0, 0);
+ cmd[0]="/bin/sh";
+ cmd[1]="-c";
+ cmd[2]=argv[1];
diff --git a/www/plugger/files/patch-plugger-helper.c b/www/plugger/files/patch-plugger-helper.c
index 6e8c951987d8..74fb8a5d6e16 100644
--- a/www/plugger/files/patch-plugger-helper.c
+++ b/www/plugger/files/patch-plugger-helper.c
@@ -1,77 +1,11 @@
---- plugger-helper.c.orig Sun Dec 9 22:41:11 2001
-+++ plugger-helper.c Sun Mar 24 23:29:20 2002
-@@ -30,6 +30,7 @@
- #include <sys/stat.h>
- #include <sys/wait.h>
- #include <errno.h>
-+#include <stdlib.h>
- #include <sys/time.h>
- #include <X11/X.h>
- #include <X11/Xos.h>
-@@ -355,10 +356,10 @@
- /* Time to steal the lock! */
- mode=PropModeReplace;
- gettimeofday(&tv, 0);
-- INC_TIME(&tv, 0, 10000 + (rand() & 16383));
-+ INC_TIME(&tv, 0, 10000 + (random() & 16383));
- break;
- }
-- my_usleep((rand() & 16383) + 2000); /* 0.18383 seconds */
-+ my_usleep((random() & 16383) + 2000); /* 0.18383 seconds */
- }
-
- D("XChangeProperty, mode=%d\n",mode);
-@@ -401,6 +402,7 @@
- got_sigwinch=1;
- }
+--- plugger-helper.c.old Wed Feb 11 16:19:27 2004
++++ plugger-helper.c Wed Feb 11 16:20:30 2004
+@@ -76,7 +76,7 @@
-+#define LONG_CHARS 12
-
- int main(int argc, char **argv)
+ static void very_low_run(char **argv)
{
-@@ -493,30 +495,30 @@
- loops=MIN(repeats,10);
- for(e=0;e<loops;e++)
- {
-- strcat(foo," ");
-- strcat(foo,file);
-+ strncat(foo," ", 1);
-+ strncat(foo,file,strlen(file));
- }
- }else{
-- sprintf(foo,"file=%s",file);
-+ snprintf(foo,strlen(file)+1+5,"file=%s",file);
- }
- putenv(foo);
- foo+=strlen(foo)+1;
- }
-
- /* setup environment variable $env */
-- sprintf(foo,"window=%ld",(long)WINDOW);
-+ snprintf(foo,LONG_CHARS+7+1,"window=%ld",(long)WINDOW);
- putenv(foo);
- foo+=strlen(foo)+1;
-
- /* setup environment variable $repeat */
-- sprintf(foo,"repeat=%ld",(long)repeats);
-+ snprintf(foo,LONG_CHARS+7+1,"repeat=%ld",(long)repeats);
- putenv(foo);
- foo+=strlen(foo)+1;
-
- /* setup environment variable $DISPLAY */
- if(displayname)
- {
-- sprintf(foo,"DISPLAY=%s",displayname);
-+ snprintf(foo,strlen(displayname)+1+8,"DISPLAY=%s",displayname);
- D("putenv(%s)\n",foo);
- putenv(foo);
- foo+=strlen(foo)+1;
-@@ -526,7 +528,7 @@
- /* setup environment variable $mimetype */
- if(mimetype)
- {
-- sprintf(foo,"mimetype=%s",mimetype);
-+ snprintf(foo,strlen(mimetype)+1+9,"mimetype=%s",mimetype);
- D("putenv(%s)\n",foo);
- putenv(foo);
- foo+=strlen(foo)+1;
+- setpgrp();
++ setpgrp(0, 0);
+ #ifdef H_NOISY
+ if(flags & H_NOISY)
+ {
diff --git a/www/plugger/files/patch-pluggerrc b/www/plugger/files/patch-pluggerrc
deleted file mode 100644
index 144864edc7ae..000000000000
--- a/www/plugger/files/patch-pluggerrc
+++ /dev/null
@@ -1,159 +0,0 @@
---- pluggerrc.orig Sun Jun 22 14:48:34 2003
-+++ pluggerrc Sun Jun 22 15:06:47 2003
-@@ -1,4 +1,4 @@
--# Configure file for plugger version 4.0
-+# Configure file for plugger version 4.0 (FreeBSD modified)
- # Commands which are not installed on your system will not
- # be used.
- #
-@@ -6,16 +6,15 @@
- video/x-mpeg: mpeg, mpg, mpe: MPEG animation
- video/x-mpeg2: mpv2, mp2ve: MPEG2 animation
- stream: mtvp -W$window - 2>/dev/null 1>/dev/null
-- ignore_errors maxaspect swallow(MPlayer):mplayer "$file" >/dev/null 2>/dev/null </dev/null
-+ nokill, ignore_errors: mplayer -really-quiet -framedrop -wid $window -aop list=volume:volume=64 "$file" >/dev/null 2>/dev/null
- loop:mtvp -l -W$window "$file"
- :mtvp -W$window "$file"
- loop: xanim +Av100 -Zr +W$window +q +f "$file"
- : xanim +Av100 -Zr +W$window +q +Ze +f "$file"
-
--
- video/msvideo: avi: AVI animation
- video/x-msvideo: avi: AVI animation
-- ignore_errors maxaspect swallow(MPlayer):if mplayer -autoq 3 "$file" 2>&1 | grep 'Sorry,' >/dev/null ; then mplayer -vo x11 -autoq 3 "$file" >/dev/null 2>/dev/null ; fi </dev/null
-+ nokill, ignore_errors: mplayer -really-quiet -framedrop -wid $window -aop list=volume:volume=64 "$file" >/dev/null 2>/dev/null
- loop:xanim +Av100 -Zr +W$window +q +f "$file"
- :xanim +Av100 -Zr +W$window +q +Ze +f "$file"
-
-@@ -37,18 +36,11 @@
- audio/midi: midi,mid: MIDI audio file
- audio/x-midi: midi,mid: MIDI audio file
- : timidity -s 48000 -a -idqqqqqqq "$file" >/dev/null 2>/dev/null
-- : playmidi $file
-
- audio/mod: mod: Soundracker audio Module
- audio/x-mod: mod: Soundracker audio Module
-- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
- loop: xmp -l --nocmd "$file" 2>/dev/null
- : xmp --nocmd "$file" 2>/dev/null
-- loop: nspmod -r "$file" 2>/dev/null 1>/dev/null
-- repeat: nspmod -l $repeat "$file" 2>/dev/null 1>/dev/null
-- : tracker -q -frequency 65000 "$file"
-- loop: mikmod -i -r "$file" 2>/dev/null 1>/dev/null
-- : mikmod -i "$file" 2>/dev/null 1>/dev/null
-
- audio/mp3: mp3: MPEG audio
- audio/x-mp3: mp3: MPEG audio
-@@ -58,15 +50,8 @@
- audio/x-mpeg3: mp3: MPEG audio
- audio/mpeg: mpa,abs,mpega: MPEG audio
- audio/x-mpeg: mpa,abs,mpega: MPEG audio
-- stream, preload: splay -t 200 -M
-- stream, preload: mpg123 -q -b 128 -
-- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
-- : mpg123 -q -b 128 "$file"
-- nokill exits:xmms "$file"
-- : splay -t 200 "$file"
-- : amp -b 200 -q "$file"
-- : maplay "$file"
-- : mpeg3play "$file"
-+ stream, preload: mpg123 -q -b 1024 -
-+ : mpg123 -q -b 1024 "$file"
-
- audio/x-sidtune: sid,psid,dat: Commodore 64 audio
- audio/sidtune: sid,psid,dat: Commodore 64 audio
-@@ -74,7 +59,6 @@
- audio/x-psid: psid,sid,dat: Commodore 64 audio
- stream: sidplay -16 -f44100 -a - >/dev/null 2>/dev/null
-
--
- audio/basic: au,snd: Basic audio file
- audio/x-basic: au,snd: Basic audio file
- loop: xanim +Av100 -Zr +W$window +q +f "$file"
-@@ -83,13 +67,7 @@
-
- audio/wav:wav:Microsoft wave file
- audio/x-wav:wav:Microsoft wave file
-- stream preload: splay -W
-- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
- : wavplay -q "$file"
-- stream preload: bplay 1>/dev/null 2>/dev/null
-- : bplay 1>/dev/null 2>/dev/null "$file"
-- : splay "$file"
-- nokill exits:xmms "$file"
- loop: xanim +Av100 -Zr +W$window +q +f "$file"
- : xanim +Av100 -Zr +W$window +q +f +Ze "$file"
-
-@@ -99,12 +77,7 @@
- image/x-png: png: PNG image
- repeat swallow(gqview) fill: gqview -t "$file" >/dev/null 2>/dev/null
- repeat swallow(display) fill: display "$file"
-- repeat swallow(Sdtimage) fill: sdtimage "$file"
-- repeat swallow(xli) fill: xli -quiet "$file" >/dev/null 2>/dev/null
-- repeat swallow(xloadimage) fill: xloadimage -quiet "$file" >/dev/null 2>/dev/null
-- exits: xloadimage -quiet -windowid $window "$file"
- exits: display -window $window -backdrop $file
-- exits: xli -quiet -windowid $window "$file"
-
- image/sun-raster: rs: SUN raster image
- image/x-sun-raster: rs: SUN raster image
-@@ -117,54 +90,34 @@
- image/x-portable-bitmap: pbm: PBM Image
- image/x-portable-anymap: pnm: PBM Image
- repeat swallow(display) fill: display "$file"
-- repeat swallow(Sdtimage) fill: sdtimage "$file"
- repeat swallow(gqview) fill: gqview -t "$file" >/dev/null 2>/dev/null
-- repeat swallow(xli) fill: xli -quiet "$file" >/dev/null 2>/dev/null
-- repeat swallow(xloadimage) fill: xloadimage -quiet "$file" >/dev/null 2>/dev/null
-- exits: xli -quiet -windowid $window "$file"
-- exits: xloadimage -quiet -windowid $window "$file"
- exits: display -window $window -backdrop $file
-
--# This does not work :(
--# swallow(XVroot) maxaspect: xv -nopos "$file"
--
- audio/mpeg-url: m3u: MPEG music resource locator
- audio/x-mpeg-url: m3u: MPEG music resource locator
- audio/mpegurl: m3u: MPEG music resource locator
- audio/x-mpegurl: m3u: MPEG music resource locator
-- nokill exits:xmms "$file"
-+ ignore_errors: mplayer -really-quiet -framedrop -demuxer 17 -playlist "$file" >/dev/null 2>/dev/null
- :internal:url
-
--audio/x-pn-realaudio-plugin:rpm:Realaudio-plugin resource locator
-- exits nokill: realplay "$file"
--
- application/pdf: pdf: PDF file
- application/x-pdf: pdf: PDF file
- text/pdf: pdf: PDF file
- text/x-pdf: pdf: PDF file
-- repeat swallow(documentShell) fill: acroread -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
-+ repeat swallow(documentShell) fill: acroread5 -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
- repeat swallow(gv) fill: gv -safer -quiet -antialias -geometry +9000+9000 "$file" 2>/dev/null
-- repeat swallow(xpdf) fill: xpdf -g +9000+9000 -err "$file"
--
--
--application/x-dvi: dvi: DVI file
-- repeat swallow(xdvi) fill: xdvi -safer -hush -geometry +9000+9000 "$file"
-
- application/x-postscript: ps: PostScript file
- application/postscript: ps: PostScript file
- repeat swallow(gv) fill: gv -safer -quiet -antialias -geometry +9000+9000 "$file" 2>/dev/null
-- repeat swallow(Pageview) fill: pageview "$file"
--
-
- application/rtf: rtf: Rich Text Format
- application/x-msword: doc, dot: Microsoft Word Document
- application/msword: doc, dot: Microsoft Word Document
- repeat swallow(AbiWord) fill: abiword -nosplash -geometry +9000+9000 "$file" >/dev/null 2>/dev/null
-- repeat swallow(PCFileViewer) fill: sdtpcv "$file"
-- repeat swallow(PCFileViewer) fill: /opt/SUNWdtpcv/bin/sdtpcv "$file"
--
-
- application/vnd.ms-excel: xls, xlb: Microsoft Excel Document
- repeat swallow(PluggerGnumeric) fill: gnumeric --class PluggerGnumeric "$file"
-- repeat swallow(PCFileViewer) fill: sdtpcv "$file"
-- repeat swallow(PCFileViewer) fill: /opt/SUNWdtpcv/bin/sdtpcv "$file"
-+
-+application/vnd.ms-powerpoint: ppt: Microsoft PowerPoint Document
-+ : nspptview "$file"
diff --git a/www/plugger/pkg-install b/www/plugger/pkg-install
new file mode 100644
index 000000000000..1801664e8673
--- /dev/null
+++ b/www/plugger/pkg-install
@@ -0,0 +1,56 @@
+#!/bin/sh
+# $FreeBSD$
+
+[ $# != 2 ] && exit 1
+PKGNAME=$1
+ACTION=$2
+
+FILES_DELETE="pluggerrc-5.0.old"
+
+ETCDIR=${PKG_PREFIX}/etc
+
+RM=/bin/rm
+CP=/bin/cp
+ECHO=/bin/echo
+
+case "$ACTION" in
+
+POST-INSTALL)
+ if [ ! -f ${ETCDIR}/pluggerrc-5.0 ]; then
+ ${CP} ${ETCDIR}/pluggerrc-5.0.sample ${ETCDIR}/pluggerrc-5.0
+ fi
+ ;;
+
+DEINSTALL)
+ for file in ${FILES_DELETE}
+ do
+ if [ -f ${ETCDIR}/${file} ]; then
+ ${RM} ${ETCDIR}/${file}
+ fi
+ done
+ ;;
+
+PRE-INSTALL)
+ ${ECHO}
+ ${ECHO} "Run ''make local-install'' as user to locally"
+ ${ECHO} "install plugger for Mozilla"
+ ${ECHO}
+ ${ECHO} "Run ''make local-opera-install'' as user to locally"
+ ${ECHO} "install plugger for Opera"
+ ${ECHO}
+ ;;
+
+POST-DEINSTALL)
+ ${ECHO}
+ ${ECHO} "If you are permanently removing this port,"
+ ${ECHO} "you should do a ''rm -f ${ETCDIR}/pluggerrc-5.0''"
+ ${ECHO} "to remove it."
+ ${ECHO}
+ ;;
+
+*)
+ exit 1
+ ;;
+esac
+
+exit
diff --git a/www/plugger/pkg-message b/www/plugger/pkg-message
deleted file mode 100644
index 659835b80fe1..000000000000
--- a/www/plugger/pkg-message
+++ /dev/null
@@ -1,36 +0,0 @@
-*****************************************************************
-*****************************************************************
-NOTE:
-
-Edit the %%PREFIX%%/etc/pluggerrc file as needed. It should work
-fine as is. If you had a previous %%PREFIX%%/etc/pluggerrc file,
-it will be renamed %%PREFIX%%/etc/pluggerrc.old.
-
-This Plugger port will install a default set of multimedia utilities
-that I have found to work well. Other combinations may work also.
-Look at the pluggerrc file for details.
-
-Plugger searches for pluggerrc files in the following order:
-
-~/.netscape/pluggerrc
-~/.mozilla/pluggerrc
-$MOZILLA_HOME/pluggerrc (MOZILLA_HOME is usually equal to HOME)
-/etc/pluggerrc
-/usr/etc/pluggerrc
-%%PREFIX%%/etc/pluggerrc
-./pluggerrc
-
-Whichever pluggerrc is found first in the above order will be
-used, no merging of other pluggerrc's occurs. You have been warned.
-
-NOTES on Sound:
-
-Remember, you have to have the Timidity patch files installed for
-it to work.
-
-Also, some of the frequency settings are extremely sound-card
-dependent. If you get no sound, adjust the frequency settings in
-your pluggerrc to be compatible with your sound card. See the
-documentation for the various sound utilities for details.
-*****************************************************************
-*****************************************************************
diff --git a/www/plugger/pkg-message-mplayer b/www/plugger/pkg-message-mplayer
deleted file mode 100644
index 32999cc3d987..000000000000
--- a/www/plugger/pkg-message-mplayer
+++ /dev/null
@@ -1,24 +0,0 @@
-####################################################################
-######################## MPLAYER NOTE ##############################
-####################################################################
-#
-# Since mplayer is run with "nokill" by plugger, it is necessary to
-# kill off the remaining mplayer processes. Something like the
-# following diff will do the trick. It's not perfect but it works.
-#
-# As suggested by D.J. Hawkey Jr.<hawkeyd@visi.com>
-#
-####################################################################
---- run-mozilla.sh.orig Sun Jun 22 09:57:27 2003
-+++ run-mozilla.sh Sun Jun 22 10:00:25 2003
-@@ -193,6 +193,10 @@
- ##
- "$prog" ${1+"$@"}
- exitcode=$?
-+ ##
-+ ## Kill any plugger artifacts
-+ ##
-+ ps -axww | awk '/mplayer.*-wid/ {print $1}' | xargs kill -9
- if [ "$DEBUG_CORE_FILES" ]
- then
- if [ -f core ]
diff --git a/www/plugger/pkg-plist b/www/plugger/pkg-plist
index eb6ef012ed0b..135d14e4d12f 100644
--- a/www/plugger/pkg-plist
+++ b/www/plugger/pkg-plist
@@ -1,6 +1,5 @@
-bin/plugger-4.0
+bin/plugger-5.0
+bin/plugger-controller
+etc/pluggerrc-5.0.sample
lib/browser_plugins/npplugger.so
-@unexec if [ -f %D/etc/pluggerrc ]; then cmp -s %D/etc/pluggerrc.sample %D/etc/pluggerrc && rm -f %D/etc/pluggerrc || echo "If you are permanently removing this port, you should do a ``rm -f ${PKG_PREFIX}/etc/pluggerrc`` to remove configuration files left." | fmt ; fi
-@unexec if [ -f %D/etc/pluggerrc.old ]; then echo "If you are permanently removing this port, you should do a ``rm -f ${PKG_PREFIX}/etc/pluggerrc.old`` to remove backup configuration files left." | fmt ; fi
-etc/pluggerrc.sample
-@exec if [ ! -f %D/etc/pluggerrc ]; then cp %D/etc/pluggerrc.sample %D/etc/pluggerrc ; fi
+@dirrm lib/browser_plugins