summaryrefslogtreecommitdiff
path: root/www/p5-HTML-Navigation/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:30:19 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:30:19 +0000
commit6ac1fcb2a40df558d1219f96364f26aee1233b69 (patch)
tree7823b7ad15b7f86989d40281b035be7205d1e87f /www/p5-HTML-Navigation/Makefile
parentAdd p5-Crypt-Twofish 1.0, perl module implementing the Twofish cipher. (diff)
Add p5-HTML-Navigation 0.26, perl module for creating generic HTML
navigation bars.
Diffstat (limited to 'www/p5-HTML-Navigation/Makefile')
-rw-r--r--www/p5-HTML-Navigation/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/p5-HTML-Navigation/Makefile b/www/p5-HTML-Navigation/Makefile
new file mode 100644
index 000000000000..fd927f801cc5
--- /dev/null
+++ b/www/p5-HTML-Navigation/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: HTML-Navigation
+# Date created: Mon Jan 1 12:02:56 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Navigation
+PORTVERSION= 0.26
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Base.pm:${PORTSDIR}/www/p5-CGI \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTML::Navigation.3
+
+.include <bsd.port.mk>