summaryrefslogtreecommitdiff
path: root/www/p5-CGI.pm/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-09-17 20:35:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-09-17 20:35:02 +0000
commit865be3a81c5f39063c2c03c740c6446957fde778 (patch)
treeddb257c9ea6f7026e20007903e321ac03f9f28fb /www/p5-CGI.pm/Makefile
parentBump PORTREVISION and expat shlib. (diff)
Long overdue update of CGI.pm:
- update to 2.86; - bump portepoch (previous version 2.753 > 2.86); - remove the requirement for 5.6.0, since it is only true for `use integer' CGI scripts; - add WWW.
Diffstat (limited to 'www/p5-CGI.pm/Makefile')
-rw-r--r--www/p5-CGI.pm/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index b3356d72feaf..a05f44645425 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= CGI.pm
-PORTVERSION= 2.753
+PORTVERSION= 2.86
+PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -14,6 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
@@ -21,6 +25,6 @@ MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
pre-patch:
- @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS/' ${WRKSRC}/Makefile.PL
+ @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS|5\.6\.0/' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>