summaryrefslogtreecommitdiff
path: root/www/p5-Apache-GopherHandler
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-08-31 17:58:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-08-31 17:58:10 +0000
commit443595e571f8ff12e52a8c66bb4167dd7daefd83 (patch)
tree68fc1e8874ae3627ebeef731ee1b9559c7014edd /www/p5-Apache-GopherHandler
parent- Update to 1.06 (diff)
- update for mod_perl2 API and unbreak
PR: 84171 Submitted by: leeym Approved by: maintainer
Diffstat (limited to 'www/p5-Apache-GopherHandler')
-rw-r--r--www/p5-Apache-GopherHandler/Makefile8
-rw-r--r--www/p5-Apache-GopherHandler/files/patch-lib-Apache-GopherHandler.pm23
2 files changed, 25 insertions, 6 deletions
diff --git a/www/p5-Apache-GopherHandler/Makefile b/www/p5-Apache-GopherHandler/Makefile
index 78a95fbfa708..ae28bb8c4686 100644
--- a/www/p5-Apache-GopherHandler/Makefile
+++ b/www/p5-Apache-GopherHandler/Makefile
@@ -15,23 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= toni.viemero@iki.fi
COMMENT= Gopher protocol implementation for Apache2
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2 \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
${SITE_PERL}/Gopher/Server/ParseRequest.pm:${PORTSDIR}/net/p5-Gopher-Server
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
-BROKEN= Broken due the new mod_perl2 API
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
MAN3= Apache::GopherHandler.3 \
Apache::GopherHandler::TiedSocket.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= "Needs perl 5.6.0 or higher, install lang/perl5 or lang/perl5.8 and try again"
+IGNORE= Needs perl 5.6.0 or higher, install lang/perl5 or lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-GopherHandler/files/patch-lib-Apache-GopherHandler.pm b/www/p5-Apache-GopherHandler/files/patch-lib-Apache-GopherHandler.pm
new file mode 100644
index 000000000000..9d7642901279
--- /dev/null
+++ b/www/p5-Apache-GopherHandler/files/patch-lib-Apache-GopherHandler.pm
@@ -0,0 +1,23 @@
+--- lib/Apache/GopherHandler.pm.orig Tue Jul 26 16:19:15 2005
++++ lib/Apache/GopherHandler.pm Tue Jul 26 16:19:33 2005
+@@ -5,9 +5,9 @@
+
+ our $VERSION = 0.1;
+
+-use Apache::Connection ();
++use Apache2::Connection ();
+ use APR::Socket ();
+-use Apache::Const -compile => 'OK';
++use Apache2::Const -compile => 'OK';
+ use Gopher::Server::ParseRequest;
+ #use Gopher::Server::RequestHandler::File;
+ use Apache::GopherHandler::TiedSocket;
+@@ -54,7 +54,7 @@
+ tie *OUT, 'Apache::GopherHandler::TiedSocket' => $socket;
+ $response->print_to( *OUT );
+
+- return Apache::OK;
++ return Apache2::Const::OK;
+ }
+
+ 1;