summaryrefslogtreecommitdiff
path: root/www/mozilla
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:21:04 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:21:04 +0000
commit1f8833e5e7e562e4d24f56238a9714857eb0685a (patch)
treeeb0701048f83c49303d9613b2cac483ab081e6e1 /www/mozilla
parentUse firefox as the default Gecko provider. (diff)
* Chase the glib20 shared lib version
* Disable cairo support as the new cairo API does not work with mozilla
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile39
-rw-r--r--www/mozilla/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--www/mozilla/pkg-deinstall.in1
-rw-r--r--www/mozilla/pkg-install.in1
4 files changed, 22 insertions, 21 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 2dd54d7ebc81..1e97fdab459d 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,11 +3,12 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/Makefile,v 1.23 2005/10/27 00:08:39 marcus Exp $
#
PORTNAME= mozilla
PORTVERSION= 1.7.12
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -99,38 +100,38 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
XMLTERM "Enable the XMLTerm module" on \
JAVASCRIPT_DEBUGGER "Enable DTD and JavaScript debuggers" off \
OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
- CAIRO_RENDER "Enable SVG rendering with Cairo" off \
SMB "Enable smb:// URI support via gnomevfs" off
+# CAIRO_RENDER "Enable SVG rendering with Cairo" off
.include <bsd.port.pre.mk>
-.if !defined(WITH_CAIRO_RENDER)
+#.if !defined(WITH_CAIRO_RENDER)
DISTFILES+= libart_lgpl-1${EXTRACT_SUFX}:local
-.endif
+#.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH} during post-build
.endif
.if exists(${LOCALBASE}/include/freetype/freetype.h)
-BROKEN= You must upgrade your freetype port to 1.3.1_2 or higher before \
+BROKEN= "You must upgrade your freetype port to 1.3.1_2 or higher before \
installing Mozilla. If you have 1.3.1_2 installed, please remove \
- ${LOCALBASE}/include/freetype, then build Mozilla
+ ${LOCALBASE}/include/freetype, then build Mozilla"
.endif
.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
defined(WITHOUT_COMPOSER))
-BROKEN= Calendar requires Composer and Mailnews support.
+BROKEN= "Calendar requires Composer and Mailnews support."
.endif
-.if defined(WITH_CAIRO_RENDER)
-LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
-BUILD_DEPENDS+= ${LOCALBASE}/include/cairo/cairo-xlib.h:${PORTSDIR}/graphics/cairo
+#.if defined(WITH_CAIRO_RENDER)
+#LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+#BUILD_DEPENDS+= ${LOCALBASE}/include/cairo/cairo-xlib.h:${PORTSDIR}/graphics/cairo
-CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
- --disable-svg-renderer-libart
-CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
-.else
+#CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+# --disable-svg-renderer-libart
+#CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+#.else
CONFIGURE_ARGS+= --enable-svg-renderer-libart \
--disable-svg-renderer-cairo
CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
@@ -140,14 +141,14 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
.else
EXTRA_PATCHES+= ${FILESDIR}/extra-patch2-nsSVGLibartGlyphMetricsFT.cpp
.endif
-.endif
+#.endif
.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+=--enable-xft
.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
+BROKEN= "Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package."
.endif
.else
CONFIGURE_ARGS+=--disable-xft
@@ -273,7 +274,7 @@ pre-install:
${RM} -rf ${FAKEDIR} ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} install
+ Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${MOZ_PIS_DIR}
${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
${FAKEDIR}/bin/mozilla \
@@ -325,7 +326,7 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's:^:@dirrm share/idl/${MOZILLA}/:' >> ${PLIST}
${ECHO_CMD} "@dirrm share/idl/${MOZILLA}" >> ${PLIST}
- ${ECHO_CMD} "@unexec rmdir %D/share/idl 2>/dev/null || true" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/idl 2>/dev/null || true" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
diff --git a/www/mozilla/files/patch-build_unix_run-mozilla.sh b/www/mozilla/files/patch-build_unix_run-mozilla.sh
index f93248fd107b..ee99123b3978 100644
--- a/www/mozilla/files/patch-build_unix_run-mozilla.sh
+++ b/www/mozilla/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,3 @@
-$FreeBSD$
-
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
+++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 329a58b212d6..b9457eff010c 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.7 2005/07/13 08:45:47 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 79a65c81189a..2b196acaf42c 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.7 2005/07/13 08:45:47 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)