summaryrefslogtreecommitdiff
path: root/www/mozilla-vendor/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-02-04 07:45:35 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-02-04 07:45:35 +0000
commit9a6c0ea2ad72860b8444fada45eae894c32f02f9 (patch)
tree9fad600775da50f34b938152f58e1ea2a6bc01e6 /www/mozilla-vendor/Makefile
parentportlint (diff)
Make M13 work on a post no-thunk-vtable 4.0-CURRENT, and enable using
poll(). Enable MathML support. Use bzip2, since it saves 5MB on the distfile. Revamp the port a bit.
Diffstat (limited to 'www/mozilla-vendor/Makefile')
-rw-r--r--www/mozilla-vendor/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/www/mozilla-vendor/Makefile b/www/mozilla-vendor/Makefile
index dd2f72e98d44..05898f3863c1 100644
--- a/www/mozilla-vendor/Makefile
+++ b/www/mozilla-vendor/Makefile
@@ -20,6 +20,8 @@ GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/mozilla
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
@@ -36,6 +38,7 @@ CONFIGURE_ARGS= \
--enable-double-buffer \
--enable-editor \
--enable-mailnews \
+ --enable-mathml \
--enable-optimize \
--enable-pics \
--enable-tests \
@@ -49,6 +52,11 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
CC_ONLY_FLAGS="${FLAGS}" CCC_ONLY_FLAGS="${CXXFLAGS}"
+post-build:
+ @${SED} -e "s;@PREFIX@;${PREFIX};g" \
+ ${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
+ @${CHMOD} 555 ${WRKSRC}/mozilla
+
do-install:
${MKDIR} ${PREFIX}/lib/mozilla
${CHMOD} 755 ${PREFIX}/lib/mozilla