summaryrefslogtreecommitdiff
path: root/www/mozex/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-07-03 06:37:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-07-03 06:37:01 +0000
commit9d2489d5bf2c0be66ec8bcbdda5594297bea03b4 (patch)
treeedda7815457338d46b5de76285704ec794e9fdcb /www/mozex/Makefile
parentUpgrade to latest (diff)
Adding www/mozex & www/mozex-firefox, external programs integration
into Mozilla / Firefox. The files Makefile.xpi and pkg-install.xpi have been designed to install any .xpi extension (hopefully). PR: ports/65589
Diffstat (limited to 'www/mozex/Makefile')
-rw-r--r--www/mozex/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/mozex/Makefile b/www/mozex/Makefile
new file mode 100644
index 000000000000..8147e7a6b4e0
--- /dev/null
+++ b/www/mozex/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: mozex
+# Date created: Sun Oct 26, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME?= mozex
+PORTVERSION= 1.07
+CATEGORIES= www mail news ftp
+MASTER_SITES= http://mozex.mozdev.org/
+
+MAINTAINER?= ports@FreeBSD.org
+COMMENT?= Mozex allows Mozilla's users to use external programs for mail, news, etc.
+
+USE_X_PREFIX= yes # Cannot be included after <bsd.port.pre.mk>.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozex/Makefile.xpi"
+
+do-install:
+ @${INSTALL_DATA} ${WRKDIR}/mozex.jar ${MOZDIR}/chrome
+
+.include <bsd.port.post.mk>