summaryrefslogtreecommitdiff
path: root/www/mod_layout/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-19 12:45:30 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-19 12:45:30 +0000
commitd134e723440ecb6a8590418df256eb17f9e10f31 (patch)
tree9c2d64b5ab15e34a0cfa28fc11381a065e5487b4 /www/mod_layout/Makefile
parentAdd FreeSCI 0.3.0, a portable interpreter for SCI games. (diff)
Add mod_layout 2.8.2, an Apache module that creates a "single look and
feel" throughout a website. PR: 23617 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'www/mod_layout/Makefile')
-rw-r--r--www/mod_layout/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/mod_layout/Makefile b/www/mod_layout/Makefile
new file mode 100644
index 000000000000..ab63ac4fc353
--- /dev/null
+++ b/www/mod_layout/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_gzip Apache module
+# Date created: Dec 18 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_layout
+PORTVERSION= 2.8.2
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.tangent.org/pub/apache/ \
+ http://www.tangent.org/mod_layout/
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+
+do-build:
+ cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -c *.c
+
+do-install:
+ cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -A -i ${PORTNAME}.so
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= DOC=''
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.html \
+ ${PREFIX}/share/doc/${PORTNAME}
+
+.else
+PLIST_SUB+= DOC='@comment '
+.endif
+
+.include <bsd.port.mk>