summaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-12-24 00:25:38 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-12-24 00:25:38 +0000
commit434b5cd24bc7b7c0cea851f7d795c15a9a9dcd39 (patch)
tree486b2fe7fe1c88e52bb3f886050d99ac94d99d7b /www/lighttpd
parent- Update to 0.11 (diff)
Add patch to fix vendor issue 2377 (SSL renegotiations) [1]
Add patch to correctly report supported network handlers (lighttpd -V) [2] References: http://redmine.lighttpd.net/issues/2377 [1] Reported by: Christos Chatzaras <chris_at_cretaforce_dot_gr> [1] [2] Obtained from: lighttpd svn rev. 2822 [1]
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile1
-rw-r--r--www/lighttpd/files/patch-src-connections.c14
-rw-r--r--www/lighttpd/files/patch-src-server.c19
3 files changed, 34 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 4ad63ee590d2..978aa0c728e3 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.30
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
diff --git a/www/lighttpd/files/patch-src-connections.c b/www/lighttpd/files/patch-src-connections.c
new file mode 100644
index 000000000000..97f25856c51f
--- /dev/null
+++ b/www/lighttpd/files/patch-src-connections.c
@@ -0,0 +1,14 @@
+Index: src/connections.c
+===================================================================
+--- src/connections.c (revision 2821)
++++ src/connections.c (revision 2822)
+@@ -1360,9 +1360,7 @@
+ }
+
+ con->renegotiations = 0;
+-#ifndef OPENSSL_NO_TLSEXT
+ SSL_set_app_data(con->ssl, con);
+-#endif
+ SSL_set_accept_state(con->ssl);
+ con->conf.is_ssl=1;
+
diff --git a/www/lighttpd/files/patch-src-server.c b/www/lighttpd/files/patch-src-server.c
new file mode 100644
index 000000000000..458b4ec5b10b
--- /dev/null
+++ b/www/lighttpd/files/patch-src-server.c
@@ -0,0 +1,19 @@
+--- src/server.c.orig 2011-12-24 01:18:53.093922971 +0100
++++ src/server.c 2011-12-24 01:18:56.738921103 +0100
+@@ -411,7 +411,7 @@
+ "\nNetwork handler:\n\n"
+ #if defined(USE_LINUX_SENDFILE) || defined(USE_FREEBSD_SENDFILE) || defined(USE_SOLARIS_SENDFILEV) || defined(USE_AIX_SENDFILE)
+ "\t+ sendfile\n"
+-#else
++#endif
+ #ifdef USE_WRITEV
+ "\t+ writev\n"
+ #else
+@@ -422,7 +422,6 @@
+ #else
+ "\t- mmap support\n"
+ #endif
+-#endif
+ "\nFeatures:\n\n"
+ #ifdef HAVE_IPV6
+ "\t+ IPv6 support\n"