summaryrefslogtreecommitdiff
path: root/www/instiki
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /www/instiki
parent- Add entry for mail/postfix-policyd-weight (diff)
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'www/instiki')
-rw-r--r--www/instiki/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index d1bd0fc9751a..dd6a217ea057 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -16,10 +16,9 @@ MAINTAINER= beech@FreeBSD.org
COMMENT= Easy to set up wiki clone implemented in ruby
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
USE_RUBY= yes
-USE_RUBY_FEATURES= 1.8
+USE_RAKE= yes
USE_LDCONFIG= yes
INSTIKIPORT?= 2500
@@ -38,7 +37,7 @@ RUBY_SHEBANG_FILES=instiki
# can't include this because it redefines do-install.
# .include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
# For now, copy and paste the definition of SPEC_DIR from the above
-REV= 1.8
+REV= ${RUBY_VER}
GEMS_BASE_DIR= lib/ruby/gems/${REV}
SPEC_DIR= ${GEMS_BASE_DIR}/specifications
BUILD_DEPENDS+= ${LOCALBASE}/${SPEC_DIR}/BlueCloth-1.0.0.gemspec:${PORTSDIR}/www/rubygem-bluecloth
@@ -53,7 +52,7 @@ post-patch:
do-build:
( cd ${WRKSRC}/db/ && \
- rake environment RAILS_ENV=production db:migrate )
+ ${RAKE_BIN} environment RAILS_ENV=production db:migrate )
do-install:
@${FIND} -E ${WRKSRC} -type f -iregex ".*\._.+" -exec ${RM} "{}" \;