summaryrefslogtreecommitdiff
path: root/www/cadaver/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-05-04 21:26:41 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-05-04 21:26:41 +0000
commita6de9bdd90f9850dfd05944758a9cec04e3473de (patch)
tree110f4ca8c25b5bd913ba3591e55f22211e916b9f /www/cadaver/Makefile
parentAdd cocktail, a set of program generators or compiler construction tools (diff)
Upgrade from 0.22.0 to 0.22.1 (April 14th). Drop expat-dependency --
this port uses whatever www/neon provides. Loosen the neon-dependency -- don't require the exact version of -lneon. Don't extract the expat and libneon bundled with the cadaver -- to avoid #include-ing a wrong header accidentally. Patch some warnings.
Diffstat (limited to '')
-rw-r--r--www/cadaver/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 356d6134b7ad..e0f98ae164b5 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -6,27 +6,31 @@
#
PORTNAME= cadaver
-PORTVERSION= 0.22.0
-PORTREVISION= 1
+PORTVERSION= 0.22.1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/cadaver/
MAINTAINER= ports@FreeBSD.org
COMMENT= Commandline client for DAV
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
- neon.24:${PORTSDIR}/www/neon
+LIB_DEPENDS= neon:${PORTSDIR}/www/neon
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-netrc \
- --with-expat
+CONFIGURE_ARGS= --enable-netrc
ALL_TARGET= cadaver
MAN1= cadaver.1
PLIST_FILES= bin/cadaver
+# Neither expat nor libneon are needed at all, but the configure
+# script breaks if it can not find the Makefile* in them. Exclude
+# them to be sure, a stray .h is not included instead of what's
+# found under PREFIX (installed by the neon port):
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
+ --exclude '${PORTNAME}-${PORTVERSION}/expat/*.[ch]' \
+ --exclude '${PORTNAME}-${PORTVERSION}/libneon/*.[ch]'
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib