summaryrefslogtreecommitdiff
path: root/www/cadaver/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /www/cadaver/Makefile
parentFix installation with PORTSDOCS (diff)
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to '')
-rw-r--r--www/cadaver/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 82a94e2050e0..8ab983662bb5 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -18,7 +18,6 @@ COMMENT= Commandline client for DAV
LIB_DEPENDS= neon:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-netrc
ALL_TARGET= cadaver
MAKE_JOBS_SAFE= yes
@@ -37,8 +36,8 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
--exclude 'glob.[ch]' --exclude 'mkstemp.[ch]' \
--exclude 'tempname.[ch]' --exclude 'basename.[ch]'
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes