summaryrefslogtreecommitdiff
path: root/www/beonex/files
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-10-07 22:23:15 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-10-07 22:23:15 +0000
commit86f732f6aa3516ef63d87cb809b7478a79129528 (patch)
tree0d02e48d766574642a05e3e0fec4b61d27f4b9d1 /www/beonex/files
parentUpdate to 0.11.4p1 (diff)
new port, based on ports/www/mozilla, of Beonex Communicator
Diffstat (limited to 'www/beonex/files')
-rw-r--r--www/beonex/files/patch-Makefile.in16
-rw-r--r--www/beonex/files/patch-basebrowser-unix28
-rw-r--r--www/beonex/files/patch-rules.mk16
-rw-r--r--www/beonex/files/patch-unix.js18
-rw-r--r--www/beonex/files/patch-xptc_platforms_unixish_x86.h27
5 files changed, 105 insertions, 0 deletions
diff --git a/www/beonex/files/patch-Makefile.in b/www/beonex/files/patch-Makefile.in
new file mode 100644
index 000000000000..7ea938ef0260
--- /dev/null
+++ b/www/beonex/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+Avoid compilation error.
+
+author: Trevor Johnson
+
+--- Makefile.in.orig Fri May 24 23:46:25 2002
++++ Makefile.in Thu Sep 26 23:45:58 2002
+@@ -169,7 +169,6 @@
+ endif
+
+ ifdef MOZ_INTERNAL_LIBART_LGPL
+-tier_9_dirs += other-licenses/libart_lgpl
+ endif
+
+ tier_9_dirs += \
diff --git a/www/beonex/files/patch-basebrowser-unix b/www/beonex/files/patch-basebrowser-unix
new file mode 100644
index 000000000000..b0ae51e2fc7e
--- /dev/null
+++ b/www/beonex/files/patch-basebrowser-unix
@@ -0,0 +1,28 @@
+$FreeBSD$
+
+"Install files necessary for viewing pages in Asian languages using
+ports based on mozilla-embedded (galeon, skipstone etc.)"
+
+author: Takashi KANAMARU <kanamaru@sekine-lab.ei.tuat.ac.jp>
+
+--- embedding/config/basebrowser-unix.orig Thu Feb 7 23:50:19 2002
++++ embedding/config/basebrowser-unix Tue Mar 12 17:06:08 2002
+@@ -203,12 +204,12 @@
+ components/unicharutil.xpt
+ components/libchardet.so
+ ; optional - on english only systems
+-; components/libucvja.so for japanese
+-; components/libucvko.so for korean
+-; components/libucvcn.so for simplified chinese
+-; components/libucvtw.so for traditional chinese
+-; components/libucvtw2.so for traditional chinese
+-; components/libucvibm.so for ibm
++components/libucvja.so
++components/libucvko.so
++components/libucvcn.so
++components/libucvtw.so
++components/libucvtw2.so
++components/libucvibm.so
+
+
+ res/language.properties
diff --git a/www/beonex/files/patch-rules.mk b/www/beonex/files/patch-rules.mk
new file mode 100644
index 000000000000..828b3ac3e3f1
--- /dev/null
+++ b/www/beonex/files/patch-rules.mk
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+Enable compilation under -CURRENT.
+
+author: Trevor Johnson
+
+--- config/rules.mk.orig Thu Aug 29 00:00:31 2002
++++ config/rules.mk Wed Oct 2 01:15:29 2002
+@@ -68,7 +68,6 @@
+ topsrcdir = $(DEPTH)
+ endif
+
+-CXX=gcc
+ LDFLAGS += -Wl,-Bstatic -Wl,-lstdc++ -Wl,-Bdynamic
+
+
diff --git a/www/beonex/files/patch-unix.js b/www/beonex/files/patch-unix.js
new file mode 100644
index 000000000000..3714c39003a2
--- /dev/null
+++ b/www/beonex/files/patch-unix.js
@@ -0,0 +1,18 @@
+$FreeBSD$
+
+"correct name of the freetype library, so that it is easier to get AA fonts
+working."
+
+author: Maxim Sobolev
+
+--- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
++++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
+@@ -227,7 +227,7 @@
+
+ // TrueType
+ pref("font.FreeType2.enable", false);
+-pref("font.freetype2.shared-library", "libfreetype.so.6");
++pref("font.freetype2.shared-library", "libfreetype.so.9");
+ // if libfreetype was built without hinting compiled in
+ // it is best to leave hinting off
+ pref("font.FreeType2.autohinted", false);
diff --git a/www/beonex/files/patch-xptc_platforms_unixish_x86.h b/www/beonex/files/patch-xptc_platforms_unixish_x86.h
new file mode 100644
index 000000000000..0a90befc070d
--- /dev/null
+++ b/www/beonex/files/patch-xptc_platforms_unixish_x86.h
@@ -0,0 +1,27 @@
+$FreeBSD$
+
+"Fix build on -CURRENT"
+
+author: Peter Kostouros <kpeter@melbpc.org.au>
+
+--- xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h.orig Fri Jun 21 01:12:40 2002
++++ xpcom/reflect/xptcall/src/md/unix/xptc_platforms_unixish_x86.h Fri Jun 21 01:41:51 2002
+@@ -94,8 +94,16 @@
+ * gcc is that the system gcc defines __FreeBSD_cc_version. This variable
+ * can also identify the period of time that 4.0-CURRENT used thunks.
+ */
+-#if defined(__FreeBSD_cc_version) && \
+- (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003)
++
++/* It seems we need to use thunks in FreeBSD -CURRENT after gcc-3.1 was merged.
++ * This solves a problem wherein regxpcom and/or regchrome would seg fault
++ * after running for a while. This problem has also exhibited itself on
++ * the alpha platform. Therefore, use thunks on all versions of
++ * -CURRENT that are using gcc-3.1.
++ */
++#if defined(__FreeBSD_cc_version) && \
++ (__FreeBSD_cc_version < 400002 || __FreeBSD_cc_version > 400003) && \
++ (__FreeBSD_cc_version < 500003)
+ #define CFRONT_STYLE_THIS_ADJUST
+ #else
+ #define THUNK_BASED_THIS_ADJUST