summaryrefslogtreecommitdiff
path: root/www/apache22
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2015-09-27 10:44:39 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2015-09-27 10:44:39 +0000
commit0046f474efd3d80626aad255c42870469dbe76a4 (patch)
tree9a15edfc88a9a5bff10648d7f4d6a0bf40af6cdd /www/apache22
parent- update to 6.49BETA5 (diff)
- fix poudriere build on FreeBSD >= 10.x with OpenSSL from ports
I haven't found the exact culprit but it seems build in poudriere behaves different. Fix build in poudriere by inspecting MAKE_ENV, else WITH_OPENSSL_PORT is not honored. Noted by: Philip Jocks <pj @ netzkommune.de>
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index a3b22638a872..e3106ad8ae2c 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -164,14 +164,13 @@ pre-configure::
@${ECHO_MSG} " You can check your modules configuration by using make show-modules"
@${ECHO_MSG} ""
+pre-configure-SSL-on::
# Fix build with OpenSSL from ports
-.if ${PORT_OPTIONS:MSSL}
-. if ${OPSYS} == FreeBSD
-. if defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != ""
+.if ${OPSYS} == FreeBSD
+. if (defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != "") || ${MAKE_ENV:M*${LOCALBASE}/openssl*}
@${ECHO_MSG} "===> apply fix for FreeBSD-${OSREL} (${OSVERSION}) for usage with ${OPENSSL_INSTALLED}"
@${ECHO_MSG} ""
${REINPLACE_CMD} -e "s|(ALL_CFLAGS)|(ALL_CFLAGS) -L${OPENSSLLIB}|" ${WRKSRC}/build/rules.mk.in
-. endif
. endif
.endif