summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-08 23:10:39 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-08 23:10:39 +0000
commit6409d34156419f29c633a186de989068c8bd95d1 (patch)
tree70f6a67a6255460755d8d19b2d73b9a06fe90432 /textproc
parentDelete *.orig after patching (fixes pkg-plist) (diff)
Add permute.
Permute is a simple program to read lines from standard input and generate all possible permutations of those lines. WWW: http://pigseye.kennesaw.edu/~rbentley/ PR: ports/85865 Submitted by: Erik Greenwald <erik@smluc.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/permute/Makefile22
-rw-r--r--textproc/permute/distinfo2
-rw-r--r--textproc/permute/files/patch-Makefile8
-rw-r--r--textproc/permute/files/patch-permute.cpp15
-rw-r--r--textproc/permute/pkg-descr4
6 files changed, 52 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b95dfd6bff9b..518a4cecd3cd 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -531,6 +531,7 @@
SUBDIR += pear-XML_HTMLSax
SUBDIR += pear-XML_Wddx
SUBDIR += perl2html
+ SUBDIR += permute
SUBDIR += php4-ctype
SUBDIR += php4-domxml
SUBDIR += php4-pspell
diff --git a/textproc/permute/Makefile b/textproc/permute/Makefile
new file mode 100644
index 000000000000..5bc8d372274f
--- /dev/null
+++ b/textproc/permute/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: permute
+# Date created: Wed Aug 07 2005
+# Whom: erik@smluc.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= permute
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://pigseye.kennesaw.edu/~rbentley/
+
+MAINTAINER= erik@smluc.org
+COMMENT= Generate all permutations of lines from stdin
+
+PLIST_FILES= bin/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/permute/distinfo b/textproc/permute/distinfo
new file mode 100644
index 000000000000..5792ad15e5d5
--- /dev/null
+++ b/textproc/permute/distinfo
@@ -0,0 +1,2 @@
+MD5 (permute-1.0.tar.gz) = 604479ddd6087f3f0b7c8ad12a9a95f5
+SIZE (permute-1.0.tar.gz) = 10489
diff --git a/textproc/permute/files/patch-Makefile b/textproc/permute/files/patch-Makefile
new file mode 100644
index 000000000000..627ccebead99
--- /dev/null
+++ b/textproc/permute/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig Fri Jul 14 14:51:01 2000
++++ Makefile Thu Sep 8 07:24:24 2005
+@@ -1,3 +1,3 @@
++all: permute
+ permute: permute.cpp
+- g++ -o permute permute.cpp
+- strip permute
++ ${CXX} ${CXXFLAGS} -o permute permute.cpp
diff --git a/textproc/permute/files/patch-permute.cpp b/textproc/permute/files/patch-permute.cpp
new file mode 100644
index 000000000000..cafa0e84e6f4
--- /dev/null
+++ b/textproc/permute/files/patch-permute.cpp
@@ -0,0 +1,15 @@
+--- permute.cpp.orig Fri Jul 14 14:51:01 2000
++++ permute.cpp Thu Sep 8 07:07:31 2005
+@@ -18,8 +18,10 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+ #include <assert.h>
+-#include <iostream.h>
+-#include <string.h>
++#include <iostream>
++#include <string>
++
++using namespace std;
+
+ //=============================================================================
+ //
diff --git a/textproc/permute/pkg-descr b/textproc/permute/pkg-descr
new file mode 100644
index 000000000000..c98ccdc97cf9
--- /dev/null
+++ b/textproc/permute/pkg-descr
@@ -0,0 +1,4 @@
+Permute is a simple program to read lines from standard input and
+generate all possible permutations of those lines.
+
+WWW: http://pigseye.kennesaw.edu/~rbentley/