summaryrefslogtreecommitdiff
path: root/textproc/xmlppm/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:34:33 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:34:33 +0000
commitca004b53c65ba92a073303a730024c27b2646268 (patch)
tree0418c8b79f3a82e7df3e57f186c434af1743333f /textproc/xmlppm/Makefile
parentUpdate to v 2.6.5. (diff)
Update to version 0.98.1
PR: ports/70635 Submitted by: Ports Fury
Diffstat (limited to 'textproc/xmlppm/Makefile')
-rw-r--r--textproc/xmlppm/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index f6949b663674..2cf652b9d82c 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= xmlppm
-PORTVERSION= 0.97
-PORTREVISION= 2
+PORTVERSION= 0.98.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.cs.cornell.edu/People/jcheney/xmlppm/
@@ -22,16 +21,22 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-USE_GMAKE= yes
USE_ICONV= yes
-MAKE_ARGS= CC="${CXX}" OPT_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_REINPLACE= yes
+USE_GMAKE= yes
+MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lexpat -liconv"
-.include <bsd.port.pre.mk>
+PORTDOCS= README
+PLIST_FILES= bin/xmlppm bin/xmlunppm
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CC|#CC|g ; \
+ s|^CPPFLAGS|#CPPFLAGS|g ; \
+ s|^CFLAGS|#CFLAGS|g ; \
+ s|$$(CC)|$$(CXX)|g ; \
+ s|$$(CFLAGS)|$$(CXXFLAGS)|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmlppm ${PREFIX}/bin
@@ -41,4 +46,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>