summaryrefslogtreecommitdiff
path: root/textproc/xmlppm/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-18 23:23:13 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-18 23:23:13 +0000
commita0c7376bfcfac99bf34f7efc9d6c864d44099993 (patch)
treead97b83c455b0fb5a57ac5dd7e2c28a99fe0f36a /textproc/xmlppm/Makefile
parentUpdate to Vim 6.1 patchlevel 474 (diff)
- update to 0.97
- install docs PR: 51703 Submitted by: Ports Fury
Diffstat (limited to 'textproc/xmlppm/Makefile')
-rw-r--r--textproc/xmlppm/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 28794790a52d..40ec7a743b52 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= xmlppm
-PORTVERSION= 0.96
-PORTREVISION= 2
+PORTVERSION= 0.97
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.cs.cornell.edu/People/jcheney/xmlppm/
@@ -18,16 +17,21 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= XML-Conscious PPM Compression
-LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
+ expat.4:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-USE_REINPLACE= yes
-USE_GMAKE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CXX}" OPT_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lexpat -liconv"
do-install:
- @(cd ${WRKSRC} ; ${INSTALL_PROGRAM} xmlppm xmlunppm ${PREFIX}/bin)
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmlppm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmlunppm ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
+.endif
.include <bsd.port.mk>