summaryrefslogtreecommitdiff
path: root/textproc/xmlindent/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-07-14 17:26:48 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-07-14 17:26:48 +0000
commitc5237459d608947f976d0f076c4cf613b2094bbd (patch)
tree78561caeeddf8400032c0adaab2ce0a8c28b38c8 /textproc/xmlindent/Makefile
parentUpdated to 0.98 (diff)
Upgrade from 0.2.5 to 0.2.8. Switch to using the bsd.prog.mk, rather
than bother patching the vendor's Makefile.
Diffstat (limited to '')
-rw-r--r--textproc/xmlindent/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/textproc/xmlindent/Makefile b/textproc/xmlindent/Makefile
index b445f3ef7d57..78312c1c962e 100644
--- a/textproc/xmlindent/Makefile
+++ b/textproc/xmlindent/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xmlindent
-PORTVERSION= 0.2.5
+PORTVERSION= 0.2.8
CATEGORIES= textproc
MASTER_SITES= http://www.cs.helsinki.fi/u/penberg/xmlindent/src/
@@ -15,9 +15,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A XML stream reformatter
MAN1= xmlindent.1
+MANCOMPRESSED= maybe
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xmlindent ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xmlindent.1 ${MANPREFIX}/man/man1
+pre-build:
+ cd ${WRKSRC} && ${MAKE} lexer
+
+.for t in build install
+do-$t:
+ cd ${WRKSRC} && ${MAKE} -f /usr/share/mk/bsd.prog.mk PROG=xmlindent \
+ SRCS="error.c indent.c buffer.c main.c" \
+ BINDIR="${PREFIX}/bin" \
+ MANDIR="${PREFIX}/man/man" \
+ ${t:build=all} LDADD=-lfl
+.endfor
.include <bsd.port.mk>