summaryrefslogtreecommitdiff
path: root/textproc/tei-p4/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-26 13:50:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-26 13:50:57 +0000
commit55a1372afdc9a7b5df78ddcc2b9a1bc196e3437a (patch)
tree65046c9140c8b1ecc8e66b5905b2e5101472c4df /textproc/tei-p4/Makefile
parent- Fix the DOCSDIR and EXAMPLESDIR code. Now both can be (diff)
- Update to latest version, fixing checksum error
- Install XML catalog - Fix catalog permissions - Change maintainer mail address PR: 58435 Submitted by: Henrik Motakef <ports@henrik-motakef.de> (maintainer)
Diffstat (limited to 'textproc/tei-p4/Makefile')
-rw-r--r--textproc/tei-p4/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/textproc/tei-p4/Makefile b/textproc/tei-p4/Makefile
index 24acaca88842..f99465f296d2 100644
--- a/textproc/tei-p4/Makefile
+++ b/textproc/tei-p4/Makefile
@@ -7,12 +7,12 @@
PORTNAME= tei
PORTVERSION= p4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://www.tei-c.org/P4X/DTD/
DISTNAME= dtd
-MAINTAINER= henrik.motakef@web.de
+MAINTAINER= ports@henrik-motakef.de
COMMENT= DTD of the Text Encoding Initiative
RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
@@ -22,14 +22,17 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_SUB= XMLCATMGR=${XMLCATMGR} \
DTDDIR=${DTDDIR} \
- CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
+ CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML} \
+ CATALOG_PORTS_XML=${CATALOG_PORTS_XML}
DTD= dtd.zip
SGMLDIR= ${PREFIX}/share/sgml
INSTDIR= ${SGMLDIR}/${PORTNAME}/${PORTVERSION}
DTDDIR= ${PORTNAME}/${PORTVERSION}
+DTD_URL= http://www.tei-c.org/Guidelines/DTD
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+CATALOG_PORTS_XML= ${PREFIX}/share/xml/catalog.ports
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -38,10 +41,13 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.dtd ${INSTDIR}
${INSTALL_DATA} ${WRKSRC}/*.ent ${INSTDIR}
${INSTALL_DATA} ${WRKSRC}/*.dec ${INSTDIR}
- ${INSTALL_DATA} ${WRKSRC}/teicatalog.xml ${INSTDIR}
+ ${SED} -e "s!${DTD_URL}!file://${INSTDIR}!" ${WRKSRC}/teicatalog.xml > ${INSTDIR}/catalog.xml
${SED} -e "s!&DTDpath;!!" ${WRKSRC}/catalog.tei > ${INSTDIR}/catalog
+ ${CHMOD} ${SHAREMODE} ${INSTDIR}/catalog.xml
+ ${CHMOD} ${SHAREMODE} ${INSTDIR}/catalog
post-install:
- ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${DTDDIR}/catalog
+ ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${INSTDIR}/catalog
+ ${XMLCATMGR} -c ${CATALOG_PORTS_XML} add nextCatalog ${INSTDIR}/catalog.xml
.include <bsd.port.mk>