summaryrefslogtreecommitdiff
path: root/textproc/p5-YAML
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-10 13:08:00 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-10 13:08:00 +0000
commit746b1f95acaf0c6fdb4d0ed8eb5b74bdbc405fb2 (patch)
treebd61802ce2cc65abaed810e9729a853dd0effdee /textproc/p5-YAML
parent- Fix build on FreeBSD 4.X (diff)
Update to 0.50. Require Perl from ports. Warn that some things might
break on 5.6.X, that is, that 5.8.3 or above is preferable.
Diffstat (limited to 'textproc/p5-YAML')
-rw-r--r--textproc/p5-YAML/Makefile45
-rw-r--r--textproc/p5-YAML/distinfo5
-rw-r--r--textproc/p5-YAML/pkg-plist19
3 files changed, 49 insertions, 20 deletions
diff --git a/textproc/p5-YAML/Makefile b/textproc/p5-YAML/Makefile
index 633912f1c0db..107e936f6577 100644
--- a/textproc/p5-YAML/Makefile
+++ b/textproc/p5-YAML/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= YAML
-PORTVERSION= 0.39
+PORTVERSION= 0.50
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= YAML
@@ -15,25 +15,44 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= YAML implementation in Perl
+BUILD_DEPENDS= \
+ p5-Spiffy>=0.25:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Test-Base>=0.45:${PORTSDIR}/devel/p5-Test-Base
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= </dev/null
-MAN1= ysh.1
-MAN3= YAML.3 YAML::Node.3
+MAN1= ysh.1
+MAN3= \
+ YAML.3 \
+ YAML::Base.3 \
+ YAML::Dumper.3 \
+ YAML::Dumper::Base.3 \
+ YAML::Error.3 \
+ YAML::Loader.3 \
+ YAML::Loader::Base.3 \
+ YAML::Marshall.3 \
+ YAML::Node.3 \
+ YAML::Tag.3 \
+ YAML::Types.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500803
post-install:
- @${ECHO} ""
- @${ECHO} "You are using an old version of Perl."
- @${ECHO} ""
- @${ECHO} "YAML.pm module is known to be buggy with your"
- @${ECHO} "version of Perl. It should mostly work, but"
- @${ECHO} "it will not be able to dump Perl code correctly."
- @${ECHO} ""
- @${ECHO} "Perhaps you should consider an upgrade."
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> You are using an old version of Perl."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> YAML.pm module is known to be buggy with your"
+ @${ECHO_MSG} "===> version of Perl. It should mostly work, but"
+ @${ECHO_MSG} "===> it will not be able to dump Perl code correctly."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "===> Perhaps you should consider an upgrade."
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-YAML/distinfo b/textproc/p5-YAML/distinfo
index 52ce3074fbef..e40686b690cb 100644
--- a/textproc/p5-YAML/distinfo
+++ b/textproc/p5-YAML/distinfo
@@ -1,2 +1,3 @@
-MD5 (YAML-0.39.tar.gz) = b8a49f49cb0ee6d9698807fb3f606922
-SIZE (YAML-0.39.tar.gz) = 61243
+MD5 (YAML-0.50.tar.gz) = 2ee010bf611f8805d95eb3867060d257
+SHA256 (YAML-0.50.tar.gz) = adc5349f8e043cd788069c7f1f3d358ff2d7f7ad10c40c6911e93b04a5f552bd
+SIZE (YAML-0.50.tar.gz) = 72505
diff --git a/textproc/p5-YAML/pkg-plist b/textproc/p5-YAML/pkg-plist
index 1094a4499fc2..5c4357ccad7c 100644
--- a/textproc/p5-YAML/pkg-plist
+++ b/textproc/p5-YAML/pkg-plist
@@ -1,10 +1,19 @@
bin/ysh
%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAML/.packlist
-%%SITE_PERL%%/YAML/Transfer.pm
-%%SITE_PERL%%/YAML/Node.pm
-%%SITE_PERL%%/YAML/Error.pm
-%%SITE_PERL%%/YAML/Family.pm
-%%SITE_PERL%%/YAML.pod
+%%SITE_PERL%%/Test/YAML.pm
%%SITE_PERL%%/YAML.pm
+%%SITE_PERL%%/YAML/Base.pm
+%%SITE_PERL%%/YAML/Dumper.pm
+%%SITE_PERL%%/YAML/Dumper/Base.pm
+%%SITE_PERL%%/YAML/Error.pm
+%%SITE_PERL%%/YAML/Loader.pm
+%%SITE_PERL%%/YAML/Loader/Base.pm
+%%SITE_PERL%%/YAML/Marshall.pm
+%%SITE_PERL%%/YAML/Node.pm
+%%SITE_PERL%%/YAML/Tag.pm
+%%SITE_PERL%%/YAML/Types.pm
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/YAML/Dumper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/YAML/Loader 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/YAML 2>/dev/null || true