summaryrefslogtreecommitdiff
path: root/textproc/opensp
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-10-31 04:33:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-10-31 04:33:39 +0000
commita5fc954d9dd6b8931e531ea42d56d4e82987ea3f (patch)
treebc6a726e7a1577d4007972aab1dc5cf4bb8741ce /textproc/opensp
parentSubmitted by: bento and kris@ (diff)
o Add explicit dependency on libiconv and gettext.
o Honor $NOPORTDOCS. PR ports/58540 Submitted by: Simon Barner <barner@in.tum.de>
Diffstat (limited to 'textproc/opensp')
-rw-r--r--textproc/opensp/Makefile42
-rw-r--r--textproc/opensp/files/patch-Makefile.in11
-rw-r--r--textproc/opensp/files/patch-aclocal.m446
-rw-r--r--textproc/opensp/files/patch-nsgmls::Makefile.in11
-rw-r--r--textproc/opensp/files/patch-sgmlnorm::Makefile11
-rw-r--r--textproc/opensp/files/patch-spam::Makefile.in11
-rw-r--r--textproc/opensp/files/patch-spcat::Makefile.in11
-rw-r--r--textproc/opensp/files/patch-spent::Makefile.in11
-rw-r--r--textproc/opensp/files/patch-sx::Makefile.in11
-rw-r--r--textproc/opensp/pkg-plist68
10 files changed, 194 insertions, 39 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index cbb821792ac5..350387027e2e 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenSP
PORTVERSION= 1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openjade
@@ -15,14 +15,32 @@ MASTER_SITE_SUBDIR= openjade
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= This package is a collection of SGML/XML tools called OpenSP
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_GMAKE= YES
+USE_REINPLACE= YES
USE_LIBTOOL= YES
USE_PERL5= yes
+USE_AUTOCONF_VER=253
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
INSTALLS_SHLIB= yes
-MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+DOC_FILES= archform.htm autoconf.htm build.htm catalog.htm charset.htm \
+ features.htm generic.htm ideas.htm index.htm new.htm \
+ nsgmls.htm sgmldecl.htm sgmlnorm.htm sgmlsout.htm spam.htm \
+ spcat.htm spent.htm sx.htm sysdecl.htm sysid.htm xml.htm \
+ xmlwarn.htm
+DOC_FILES2= NEWS AUTHORS README \
+ releasenotes.html releasenotes.pdf releasenotes.ps
+
+# Perhaps this better should be somewhere under ${PREFIX}/share/doc ?
+DOCSDIR2= ${PREFIX}/share/sgml/openjade/doc/OpenSP
.include <bsd.port.pre.mk>
@@ -32,4 +50,24 @@ MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
# other than -O{0,1,}. Idea taken from palm/prc-tools-gcc.
CPPFLAGS:= -O ${CFLAGS:N-O*:N-m*}
+pre-install:
+ @${REINPLACE_CMD} -e \
+ 's|install-man install-pkgdocDATA|install-man|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}
+.endfor
+
+ @${MKDIR} ${DOCSDIR2}
+.for doc in ${DOC_FILES2}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR2}
+.endfor
+
+.endif
+
.include <bsd.port.post.mk>
diff --git a/textproc/opensp/files/patch-Makefile.in b/textproc/opensp/files/patch-Makefile.in
new file mode 100644
index 000000000000..579888378668
--- /dev/null
+++ b/textproc/opensp/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Oct 31 10:13:26 2003
++++ Makefile.in Fri Oct 31 10:13:32 2003
+@@ -107,7 +107,7 @@
+
+ AUTOMAKE_OPTIONS = check-news
+
+-SUBDIRS = pubtext unicode doc \
++SUBDIRS = pubtext unicode \
+ include generic \
+ lib nsgmls spent spam sgmlnorm sx spcat \
+ intl po
diff --git a/textproc/opensp/files/patch-aclocal.m4 b/textproc/opensp/files/patch-aclocal.m4
new file mode 100644
index 000000000000..63e17ff1b43c
--- /dev/null
+++ b/textproc/opensp/files/patch-aclocal.m4
@@ -0,0 +1,46 @@
+
+$FreeBSD: /tmp/pcvs/ports/textproc/opensp/files/Attic/patch-aclocal.m4,v 1.1 2003-10-31 04:33:39 kuriyama Exp $
+
+--- aclocal.m4.orig Wed Jul 17 20:48:30 2002
++++ aclocal.m4 Thu Jul 18 16:38:49 2002
+@@ -545,7 +545,7 @@
+ rm -f conf.gdk_pixbuftest
+ ])
+
+-# gettext.m4 serial 13 (gettext-0.11.1)
++# gettext.m4 serial 14 (gettext-0.11.2)
+ dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
+ dnl This file is free software, distributed under the terms of the GNU
+ dnl General Public License. As a special exception to the GNU General
+@@ -689,14 +689,13 @@
+ dnl Now see whether libintl exists and does not depend on libiconv.
+ AC_TRY_LINK([#include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ gt_cv_func_gnugettext_libintl=yes,
+ gt_cv_func_gnugettext_libintl=no)
+ dnl Now see whether libintl exists and depends on libiconv.
+@@ -704,14 +703,13 @@
+ LIBS="$LIBS $LIBICONV"
+ AC_TRY_LINK([#include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ [LIBINTL="$LIBINTL $LIBICONV"
+ LTLIBINTL="$LTLIBINTL $LTLIBICONV"
+ gt_cv_func_gnugettext_libintl=yes
diff --git a/textproc/opensp/files/patch-nsgmls::Makefile.in b/textproc/opensp/files/patch-nsgmls::Makefile.in
new file mode 100644
index 000000000000..27361cce0be1
--- /dev/null
+++ b/textproc/opensp/files/patch-nsgmls::Makefile.in
@@ -0,0 +1,11 @@
+--- nsgmls/Makefile.in.orig Sat Oct 25 21:23:36 2003
++++ nsgmls/Makefile.in Sat Oct 25 21:23:48 2003
+@@ -142,7 +142,7 @@
+ nsgmls_inst.$(OBJEXT)
+ onsgmls_OBJECTS = $(am_onsgmls_OBJECTS)
+ onsgmls_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-onsgmls_LDFLAGS =
++onsgmls_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/files/patch-sgmlnorm::Makefile b/textproc/opensp/files/patch-sgmlnorm::Makefile
new file mode 100644
index 000000000000..c08a9a4c4029
--- /dev/null
+++ b/textproc/opensp/files/patch-sgmlnorm::Makefile
@@ -0,0 +1,11 @@
+--- sgmlnorm/Makefile.in.orig Sat Oct 25 21:24:54 2003
++++ sgmlnorm/Makefile.in Sat Oct 25 21:25:06 2003
+@@ -136,7 +136,7 @@
+ am_osgmlnorm_OBJECTS = sgmlnorm.$(OBJEXT) SGMLGenerator.$(OBJEXT)
+ osgmlnorm_OBJECTS = $(am_osgmlnorm_OBJECTS)
+ osgmlnorm_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-osgmlnorm_LDFLAGS =
++osgmlnorm_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/files/patch-spam::Makefile.in b/textproc/opensp/files/patch-spam::Makefile.in
new file mode 100644
index 000000000000..4db774302a09
--- /dev/null
+++ b/textproc/opensp/files/patch-spam::Makefile.in
@@ -0,0 +1,11 @@
+--- spam/Makefile.in.orig Sat Oct 25 21:11:02 2003
++++ spam/Makefile.in Sat Oct 25 21:11:13 2003
+@@ -138,7 +138,7 @@
+ MarkupEventHandler.$(OBJEXT) spam_inst.$(OBJEXT)
+ ospam_OBJECTS = $(am_ospam_OBJECTS)
+ ospam_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-ospam_LDFLAGS =
++ospam_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/files/patch-spcat::Makefile.in b/textproc/opensp/files/patch-spcat::Makefile.in
new file mode 100644
index 000000000000..dab83cfded01
--- /dev/null
+++ b/textproc/opensp/files/patch-spcat::Makefile.in
@@ -0,0 +1,11 @@
+--- spcat/Makefile.in.orig Sat Oct 25 22:06:38 2003
++++ spcat/Makefile.in Sat Oct 25 22:06:54 2003
+@@ -134,7 +134,7 @@
+ am_ospcat_OBJECTS = spcat.$(OBJEXT) spcat_inst.$(OBJEXT)
+ ospcat_OBJECTS = $(am_ospcat_OBJECTS)
+ ospcat_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-ospcat_LDFLAGS =
++ospcat_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/files/patch-spent::Makefile.in b/textproc/opensp/files/patch-spent::Makefile.in
new file mode 100644
index 000000000000..274192aa0981
--- /dev/null
+++ b/textproc/opensp/files/patch-spent::Makefile.in
@@ -0,0 +1,11 @@
+--- spent/Makefile.in.orig Sat Oct 25 21:09:41 2003
++++ spent/Makefile.in Sat Oct 25 21:09:57 2003
+@@ -134,7 +134,7 @@
+ am_ospent_OBJECTS = spent.$(OBJEXT)
+ ospent_OBJECTS = $(am_ospent_OBJECTS)
+ ospent_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-ospent_LDFLAGS =
++ospent_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/files/patch-sx::Makefile.in b/textproc/opensp/files/patch-sx::Makefile.in
new file mode 100644
index 000000000000..121ff176b977
--- /dev/null
+++ b/textproc/opensp/files/patch-sx::Makefile.in
@@ -0,0 +1,11 @@
+--- sx/Makefile.in.orig Sat Oct 25 21:26:34 2003
++++ sx/Makefile.in Sat Oct 25 21:27:03 2003
+@@ -140,7 +140,7 @@
+ sx_inst.$(OBJEXT)
+ osx_OBJECTS = $(am_osx_OBJECTS)
+ osx_DEPENDENCIES = $(top_builddir)/lib/libosp.la
+-osx_LDFLAGS =
++osx_LDFLAGS = -lintl
+
+ DEFS = @DEFS@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
diff --git a/textproc/opensp/pkg-plist b/textproc/opensp/pkg-plist
index 57363dc6951c..62c2f6f18c6a 100644
--- a/textproc/opensp/pkg-plist
+++ b/textproc/opensp/pkg-plist
@@ -141,33 +141,32 @@ include/OpenSP/rtti.h
include/OpenSP/sptchar.h
include/OpenSP/types.h
include/OpenSP/xnew.h
-lib/charset.alias
lib/libosp.a
lib/libosp.la
lib/libosp.so
lib/libosp.so.3
-share/doc/OpenSP/archform.htm
-share/doc/OpenSP/autoconf.htm
-share/doc/OpenSP/build.htm
-share/doc/OpenSP/catalog.htm
-share/doc/OpenSP/charset.htm
-share/doc/OpenSP/features.htm
-share/doc/OpenSP/generic.htm
-share/doc/OpenSP/ideas.htm
-share/doc/OpenSP/index.htm
-share/doc/OpenSP/new.htm
-share/doc/OpenSP/nsgmls.htm
-share/doc/OpenSP/sgmldecl.htm
-share/doc/OpenSP/sgmlnorm.htm
-share/doc/OpenSP/sgmlsout.htm
-share/doc/OpenSP/spam.htm
-share/doc/OpenSP/spcat.htm
-share/doc/OpenSP/spent.htm
-share/doc/OpenSP/sx.htm
-share/doc/OpenSP/sysdecl.htm
-share/doc/OpenSP/sysid.htm
-share/doc/OpenSP/xml.htm
-share/doc/OpenSP/xmlwarn.htm
+%%PORTDOCS%%%%DOCSDIR%%/archform.htm
+%%PORTDOCS%%%%DOCSDIR%%/autoconf.htm
+%%PORTDOCS%%%%DOCSDIR%%/build.htm
+%%PORTDOCS%%%%DOCSDIR%%/catalog.htm
+%%PORTDOCS%%%%DOCSDIR%%/charset.htm
+%%PORTDOCS%%%%DOCSDIR%%/features.htm
+%%PORTDOCS%%%%DOCSDIR%%/generic.htm
+%%PORTDOCS%%%%DOCSDIR%%/ideas.htm
+%%PORTDOCS%%%%DOCSDIR%%/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/new.htm
+%%PORTDOCS%%%%DOCSDIR%%/nsgmls.htm
+%%PORTDOCS%%%%DOCSDIR%%/sgmldecl.htm
+%%PORTDOCS%%%%DOCSDIR%%/sgmlnorm.htm
+%%PORTDOCS%%%%DOCSDIR%%/sgmlsout.htm
+%%PORTDOCS%%%%DOCSDIR%%/spam.htm
+%%PORTDOCS%%%%DOCSDIR%%/spcat.htm
+%%PORTDOCS%%%%DOCSDIR%%/spent.htm
+%%PORTDOCS%%%%DOCSDIR%%/sx.htm
+%%PORTDOCS%%%%DOCSDIR%%/sysdecl.htm
+%%PORTDOCS%%%%DOCSDIR%%/sysid.htm
+%%PORTDOCS%%%%DOCSDIR%%/xml.htm
+%%PORTDOCS%%%%DOCSDIR%%/xmlwarn.htm
share/sgml/openjade/OpenSP/HTML32.dcl
share/sgml/openjade/OpenSP/HTML32.dtd
share/sgml/openjade/OpenSP/HTML32.soc
@@ -196,20 +195,15 @@ share/sgml/openjade/OpenSP/unicode.sd
share/sgml/openjade/OpenSP/unicode.syn
share/sgml/openjade/OpenSP/xml.dcl
share/sgml/openjade/OpenSP/xml.soc
-share/sgml/openjade/doc/OpenSP/ABOUT-NLS
-share/sgml/openjade/doc/OpenSP/AUTHORS
-share/sgml/openjade/doc/OpenSP/COPYING
-share/sgml/openjade/doc/OpenSP/ChangeLog
-share/sgml/openjade/doc/OpenSP/NEWS
-share/sgml/openjade/doc/OpenSP/README
-share/sgml/openjade/doc/OpenSP/releasenotes.html
-share/sgml/openjade/doc/OpenSP/releasenotes.pdf
-share/sgml/openjade/doc/OpenSP/releasenotes.ps
-share/sgml/openjade/locale/locale.alias
-@dirrm share/doc/OpenSP
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/AUTHORS
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/NEWS
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/README
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/releasenotes.html
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/releasenotes.pdf
+%%PORTDOCS%%share/sgml/openjade/doc/OpenSP/releasenotes.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/OpenSP
@dirrm share/sgml/openjade/OpenSP
-@dirrm share/sgml/openjade/doc/OpenSP
-@dirrm share/sgml/openjade/doc
-@dirrm share/sgml/openjade/locale
+%%PORTDOCS%%@dirrm share/sgml/openjade/doc/OpenSP
+%%PORTDOCS%%@dirrm share/sgml/openjade/doc
@dirrm share/sgml/openjade