summaryrefslogtreecommitdiff
path: root/textproc/meld
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-12 02:41:26 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-12 02:41:26 +0000
commitddabb4ef268807e9b5acd4eb9e22a0032ce5b763 (patch)
tree9b94be9ba6ca14061794f6aafc10cf5df31247e4 /textproc/meld
parento Replace openldap20 dependency on openldap21 (diff)
o PREFIX safeness: remove hardcoded path
o Fix timezone offset in CVS view (and make it usable) PR: 53087 Submitted by: maintainer
Diffstat (limited to 'textproc/meld')
-rw-r--r--textproc/meld/Makefile3
-rw-r--r--textproc/meld/files/patch-cvsview.py11
2 files changed, 14 insertions, 0 deletions
diff --git a/textproc/meld/Makefile b/textproc/meld/Makefile
index 37996836ad86..ab2cd49fe267 100644
--- a/textproc/meld/Makefile
+++ b/textproc/meld/Makefile
@@ -24,6 +24,9 @@ USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|os.path.dirname(sys.argv\[0\])|"${PYTHON_SITELIBDIR}/meldapp"|' ${WRKSRC}/misc.py
@${REINPLACE_CMD} -e 's|/"+os.path.abspath(misc.appdir("manual/index.html") )|${PREFIX}/share/doc/meld/index.html"|' ${WRKSRC}/meldapp.py
+ @${REINPLACE_CMD} \
+ -e 's|/usr/share/pixmaps|${X11BASE}/share/gnome/pixmaps|' \
+ ${WRKSRC}/cvsview.py
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/meld ${PREFIX}/bin
diff --git a/textproc/meld/files/patch-cvsview.py b/textproc/meld/files/patch-cvsview.py
new file mode 100644
index 000000000000..a3da8878254f
--- /dev/null
+++ b/textproc/meld/files/patch-cvsview.py
@@ -0,0 +1,11 @@
+--- cvsview.py.orig Wed Jun 11 23:35:31 2003
++++ cvsview.py Wed Jun 11 23:36:04 2003
+@@ -90,7 +90,7 @@
+ if plus >= 0:
+ cotime = 0
+ try:
+- cotime = time.mktime( time.strptime(date) )
++ cotime = time.mktime( time.strptime(date) ) - time.timezone
+ except ValueError, e:
+ if not date.startswith("Result of merge"):
+ print "Unable to parse date '%s' in '%s/CVS/Entries'" % (date, directory)