summaryrefslogtreecommitdiff
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-15 22:50:34 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-15 22:50:34 +0000
commit7b5694631cd882d440a1432b3bafb8087427119a (patch)
tree9159da8e5d440107e9b64fea5b0a6271a3f28efb /textproc/libxml2
parentAdd 'ipv6' on CATEGORIES. Icecast2 supports IPv6 streaming. (diff)
Re-add a patch that was forgotten when libxml2 was upgraded to 2.4.27.
This will get us closer to eliminating HTTP traffic when searching for DTDs. However, since we no longer offer the docbook 4.1.2 DTDs in ports, this still doesn't solve the problem. Work is now being done to offer a better overall solution.
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/libxml2/files/patch-catalog.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 19ad6b60b898..23b6070a5434 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.4.28
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
diff --git a/textproc/libxml2/files/patch-catalog.c b/textproc/libxml2/files/patch-catalog.c
new file mode 100644
index 000000000000..bb69882c95d3
--- /dev/null
+++ b/textproc/libxml2/files/patch-catalog.c
@@ -0,0 +1,15 @@
+--- catalog.c.orig Wed Jan 15 17:35:09 2003
++++ catalog.c Wed Jan 15 17:36:03 2003
+@@ -56,10 +56,10 @@
+ #define XML_URN_PUBID "urn:publicid:"
+ #define XML_CATAL_BREAK ((xmlChar *) -1)
+ #ifndef XML_XML_DEFAULT_CATALOG
+-#define XML_XML_DEFAULT_CATALOG "file:///etc/xml/catalog"
++#define XML_XML_DEFAULT_CATALOG "file://%%LOCALBASE%%/share/xml/catalog"
+ #endif
+ #ifndef XML_SGML_DEFAULT_CATALOG
+-#define XML_SGML_DEFAULT_CATALOG "file:///etc/sgml/catalog"
++#define XML_SGML_DEFAULT_CATALOG "file://%%LOCALBASE%%/share/sgml/catalog"
+ #endif
+
+ static int xmlExpandCatalog(xmlCatalogPtr catal, const char *filename);