summaryrefslogtreecommitdiff
path: root/textproc/highlight/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-08-10 23:39:33 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-08-10 23:39:33 +0000
commit195c351e6b831906e8c9231fcad5d01be27294fa (patch)
treee699bf148313791028c3a0a3c5945d7546d37aa9 /textproc/highlight/Makefile
parentDrop maintainership (diff)
Add highlight.
highlight is a customizable source code highlighter. It supports a myriad of output formats, and an even greater myriad of recognized source code formats, and even supports themes. highlight can output to HTML, XHTML, RTF, LaTeX and TeX, and can markup many input formats, including: Ada 95, Agda, AMPL, Aspect, Assembler, Amtrix, Avenue, (G)AWK, Bash, BlitzBasic, BMS, C, C++, C#, ClearBasic, Clipper, COBOL, CSS, DOS-Batch, Eiffel, Euphoria, Express, Fortran, Haskell, HTML, HTTPD, IDL, INI, Jasmin, Java, JavaScript, LaTeX, LDIF, Lotus Script, Lua, Make, Maya, Matlab, Modelica, Modula 3, (Object) Pascal, Paradox, PATROL, Perl, PHP, Pike, PL/1, PL/SQL, POV Ray, Progress, Python, Rexx, Ruby, Small, Spin, Sybase, VHDL, Visual Basic, and XML. phew!
Diffstat (limited to 'textproc/highlight/Makefile')
-rw-r--r--textproc/highlight/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
new file mode 100644
index 000000000000..19887d5f69b8
--- /dev/null
+++ b/textproc/highlight/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: highlight
+# Date created: 05 August 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= highlight
+PORTVERSION= 2.0d7 #someday, people will stick to numbers and decimal points
+CATEGORIES= textproc
+MASTER_SITES= http://www.andre-simon.de/zip/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/d/-/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Customizable syntax highlighter
+
+WRKSRC= ${WRKDIR}/${PORTNAME}2
+
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.if !defined(NOPORTDOCS)
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/highlight|${DATADIR}|' \
+ ${WRKSRC}/${PORTNAME}/datadir.cpp
+
+do-install:
+ cd ${WRKSRC} && ${GMAKE} ${INSTALL_TARGET}
+ ${MKDIR} ${DATADIR} ${EXAMPLESDIR} ${DOCSDIR}
+ ${MKDIR} ${DATADIR}/helpmsg ${DATADIR}/langDefs ${DATADIR}/themes
+ ${INSTALL_DATA} ${WRKSRC}/helpmsg/* ${DATADIR}/helpmsg
+ ${INSTALL_DATA} ${WRKSRC}/langDefs/*.lang ${DATADIR}/langDefs
+ ${INSTALL_DATA} ${WRKSRC}/langDefs/extensions.conf ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/themes/* ${DATADIR}/themes
+ ${INSTALL_DATA} ${WRKSRC}/cgi/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1}.gz ${MANPREFIX}/man/man1
+.for i in AUTHORS README ChangeLog COPYING INSTALL
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif # !defined(NOPORTDOCS)
+
+.include <bsd.port.mk>