summaryrefslogtreecommitdiff
path: root/textproc/bsddiff/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-06-19 21:18:28 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-06-19 21:18:28 +0000
commit76fd880143cec3f975acf30787b506cd6d85c039 (patch)
tree0b83208b25280114e3d5627a191b4d8925a528b4 /textproc/bsddiff/Makefile
parentUpgrade to iReport-2.0.0. (diff)
This is the BSD-licensed version of the well-known diff utility, obtained from
OpenBSD. It lacks some features of GNU diff. It is a proposed project idea to replace the GNU diff with this one, but it needs to be completed first. Patches are highly appreciated. WWW: http://www.freebsd.org/projects/ideas/#p-bsdtexttools Obtained from: OpenBSD
Diffstat (limited to 'textproc/bsddiff/Makefile')
-rw-r--r--textproc/bsddiff/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/bsddiff/Makefile b/textproc/bsddiff/Makefile
new file mode 100644
index 000000000000..24ee5f42058d
--- /dev/null
+++ b/textproc/bsddiff/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: bsd-diff
+# Date created: 12 Juni 2007
+# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diff
+PORTVERSION= 20070612
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= gabor
+PKGNAMEPREFIX= bsd-
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= BSD-licensed version of diff from OpenBSD
+
+MANCOMPRESSED= yes
+MAN1= diff.1
+PLIST_FILES= bin/diff
+
+MAKE_ENV+= BINDIR="${PREFIX}/bin" \
+ MANDIR="${MANPREFIX}/man/man" \
+ CATDIR="${MANPREFIX}/man/man"
+
+.include <bsd.port.mk>