summaryrefslogtreecommitdiff
path: root/textproc/bbe/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-09 01:43:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-09 01:43:48 +0000
commit6f3b0763961863eba3c08b9575f165cfa90691a3 (patch)
treefdc47cc8012520b17b7127991f1a3d3e7f5b20d1 /textproc/bbe/Makefile
parent- Update to 0.69 (diff)
Add bbe 0.2.2, a sed-like editor for binary files.
PR: ports/105314 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'textproc/bbe/Makefile')
-rw-r--r--textproc/bbe/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/bbe/Makefile b/textproc/bbe/Makefile
new file mode 100644
index 000000000000..3d580d3a2faf
--- /dev/null
+++ b/textproc/bbe/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bbe
+# Date created: 8 November 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbe
+PORTVERSION= 0.2.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}-
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A sed-like editor for binary files
+
+HAS_CONFIGURE= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+DOCS= AUTHORS ChangeLog README
+PORTDOCS= bbe.html ${DOCS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/bbe.html ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>