summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-04-10 21:37:43 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-04-10 21:37:43 +0000
commitca702b7472a02765c85493e45500186c4cdaaf5d (patch)
tree17c9cb042125929039544777dd37d88a391a840e /sysutils
parent- Fix dependencies, unbreak (diff)
BROKEN on 4.x: Does not compile
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine2/Makefile8
-rw-r--r--sysutils/dd_rescue/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/sysutils/cfengine2/Makefile b/sysutils/cfengine2/Makefile
index eb635fe260a5..bad9c0f2275e 100644
--- a/sysutils/cfengine2/Makefile
+++ b/sysutils/cfengine2/Makefile
@@ -39,4 +39,10 @@ LDFLAGS+= -L${LOCALBASE}/lib/db41 -ldb41
.error WITH_BDB_VER must be 41 or 42
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index 293e6e98e2d9..2b4e5098f74b 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -16,6 +16,12 @@ COMMENT= A dd tool suitable for rescuing data from a medium with errors
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= default
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dd_rescue ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -23,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.dd_rescue ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>