summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:19:21 +0000
commit38ae599271006aa4aa581f0b03a8a5014fcf143d (patch)
tree1a1f5120bedb0bac581913ebf46122f0c3c9a656 /sysutils
parentUpdate to 2.2.1 (diff)
Extensive patchfile cleanups using sobomax's wonderful
post-extract rule
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gnome-system-monitor/Makefile7
-rw-r--r--sysutils/gnomesystemmonitor/Makefile7
-rw-r--r--sysutils/gtop/Makefile7
3 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index c79252288cf2..6225412c3704 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -26,4 +26,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
index c79252288cf2..6225412c3704 100644
--- a/sysutils/gnomesystemmonitor/Makefile
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -26,4 +26,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/sysutils/gtop/Makefile b/sysutils/gtop/Makefile
index c79252288cf2..6225412c3704 100644
--- a/sysutils/gtop/Makefile
+++ b/sysutils/gtop/Makefile
@@ -26,4 +26,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>