summaryrefslogtreecommitdiff
path: root/sysutils/xfce4-utils/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-10-19 06:13:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-10-19 06:13:49 +0000
commita1c8691e690406dc43bdfbeba1f767ec9c888a56 (patch)
treefa72be9fca7f271adafce1ba7c41564af40b9142 /sysutils/xfce4-utils/Makefile
parentUpdate Mozilla to 1.5, and adjust the dependent ports accordingly. Note, (diff)
- Get the translations installed (Make configure able to detect
gettext and add it to LIB_DEPENDS.). [1] - INSTALLS_SHLIB added to the Makefile (Only in case a library get installed by the port.) - remove NO_FILTER_SHLIB - Replaced GNU_CONFIGURE with USE_LIBTOOL if INSTALLS_SHLIB was set in the Makefile - bump PORTREVISION Noted By: Dinesh Nadarajah <dinesh_list@sbcglobal.net> [1]
Diffstat (limited to 'sysutils/xfce4-utils/Makefile')
-rw-r--r--sysutils/xfce4-utils/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/xfce4-utils/Makefile b/sysutils/xfce4-utils/Makefile
index 1ba831dfcab7..ad5d372ea938 100644
--- a/sysutils/xfce4-utils/Makefile
+++ b/sysutils/xfce4-utils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-utils
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= sysutils xfce
MASTER_SITES= http://www.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://linux.imp.mx/xfce4/xfce_${PORTVERSION}/src/
@@ -16,13 +17,18 @@ DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 essential utilities and scripts
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
xfce4mcs-manager.1:${PORTSDIR}/sysutils/xfce4-mcs-manager
USE_GNOME= gtk20
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>