summaryrefslogtreecommitdiff
path: root/sysutils/xfce4-fsguard-plugin/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-24 06:13:15 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-24 06:13:15 +0000
commit6f708353fdb3a1c8b6bd912dd4b7381b4c19929c (patch)
tree4c47981f719ebe409d93c3e928ab254ed2c2e590 /sysutils/xfce4-fsguard-plugin/Makefile
parentUpgrade to 1.2.4. (diff)
Add xfce4-fsguard-plugin 0.2.0:
Written by Andre Lerche, this plugin checks the chosen mountpoint for free disk space. It displays 4 different icons (red, yellow, green, unknown) and a message box, depending on the free space. The amount of free disk space is visible in a tooltip. If you left-click on its icon, it opens the mountpoint directory in the file manager. Author: Andre Lerche <a.lerche@gmx.net> WWW: http://xfce-goodies.berlios.de/ PR: 60421 Submitted by: Matt Lancereau <matt@rimasec.net>
Diffstat (limited to 'sysutils/xfce4-fsguard-plugin/Makefile')
-rw-r--r--sysutils/xfce4-fsguard-plugin/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/xfce4-fsguard-plugin/Makefile b/sysutils/xfce4-fsguard-plugin/Makefile
new file mode 100644
index 000000000000..975a6bb06526
--- /dev/null
+++ b/sysutils/xfce4-fsguard-plugin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xfce4-fsguard-plugin
+# Date created: 2003-12-20
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-fsguard-plugin
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+
+MAINTAINER= matt@rimasec.net
+COMMENT= XFce4 panel plugin to check a mountpoint for free disk space
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>