summaryrefslogtreecommitdiff
path: root/sysutils/rdiff-backup/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 08:32:25 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-07-03 08:32:25 +0000
commitb43237872adcbf01072e8127ff635c24bb8d0bf0 (patch)
tree75ed083fa71fa00c83a32117b15aa451bc03326a /sysutils/rdiff-backup/Makefile
parentHand maintainership to submitter (diff)
add rdiff-backup
WWW: http://rdiff-backup.stanford.edu/ PR: 53234 Submitted by: Gerhard Haering <gh@ghaering.de>
Diffstat (limited to 'sysutils/rdiff-backup/Makefile')
-rw-r--r--sysutils/rdiff-backup/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/rdiff-backup/Makefile b/sysutils/rdiff-backup/Makefile
new file mode 100644
index 000000000000..7d4fcff8130c
--- /dev/null
+++ b/sysutils/rdiff-backup/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: rdiff-backup
+# Date created: Wed Jun 11 19:53:46 CEST 2003
+# Whom: Gerhard Häring <gh@ghaering.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rdiff-backup
+PORTVERSION= 0.12.0
+CATEGORIES= sysutils
+MASTER_SITES= http://rdiff-backup.stanford.edu/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gh@ghaering.de
+COMMENT= Local/remote mirroring+incremental backup
+
+LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+MAN1= rdiff-backup.1
+
+DOCFILES= CHANGELOG README COPYING FAQ.html
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/rdiff-backup.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>