summaryrefslogtreecommitdiff
path: root/sysutils/pprotectd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-08-08 20:07:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-08-08 20:07:22 +0000
commit63cc16e46f32a477dd13754caf4e7044002a060e (patch)
treebfef59bf220d5369b44b47d310e5c581755b3a24 /sysutils/pprotectd/Makefile
parent- Reviwe flock (diff)
pprotectd this is a self protected daemon which protect processes
from killing by the kernel when memory is exhausted. The P_PROTECTED flag protects processes from killing by the kernel when memory is exhausted. This may be useful for protection many critical daemons, such as cron, syslogd, inetd, sshd or mysqld. WWW: http://www.zonov.org/ PR: ports/151774 Submitted by: Andrey Zonov <andrey.zonov@gmail.com>
Diffstat (limited to 'sysutils/pprotectd/Makefile')
-rw-r--r--sysutils/pprotectd/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/pprotectd/Makefile b/sysutils/pprotectd/Makefile
new file mode 100644
index 000000000000..6f2fc39dd7e3
--- /dev/null
+++ b/sysutils/pprotectd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pprotectd
+# Date created: 15 July 2010
+# Whom: Andrey Zonov <andrey@zonov.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pprotectd
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.zonov.org/${PORTNAME}/
+
+MAINTAINER= andrey@zonov.org
+COMMENT= A daemon that protects processes from killing when memory is exhausted
+
+USE_RC_SUBR= ${PORTNAME}
+
+PLIST_FILES= sbin/${PORTNAME}
+MAN8= ${PORTNAME}.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>